summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-06-24 11:55:04 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-06-24 11:55:04 +0200
commit70b7817063a52e63879baecddfb38f2ea8a85e6a (patch)
tree1d541a16298663419e674165f814d900435f1917 /dev-ml/ocamldsort/ocamldsort-0.16.0-r1.ebuild
parentdev-ml/ocaml-data-notation: drop backward compat dep on camlp4 (diff)
downloadgentoo-70b7817063a52e63879baecddfb38f2ea8a85e6a.tar.gz
gentoo-70b7817063a52e63879baecddfb38f2ea8a85e6a.tar.bz2
gentoo-70b7817063a52e63879baecddfb38f2ea8a85e6a.zip
dev-ml/ocamldsort: drop backward compat dep on camlp4
Package-Manager: portage-2.3.0 RepoMan-Options: --force
Diffstat (limited to 'dev-ml/ocamldsort/ocamldsort-0.16.0-r1.ebuild')
-rw-r--r--dev-ml/ocamldsort/ocamldsort-0.16.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/ocamldsort/ocamldsort-0.16.0-r1.ebuild b/dev-ml/ocamldsort/ocamldsort-0.16.0-r1.ebuild
new file mode 100644
index 000000000000..c5716d5b22d7
--- /dev/null
+++ b/dev-ml/ocamldsort/ocamldsort-0.16.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A dependency sorter for OCaml source files"
+HOMEPAGE="http://dimitri.mutu.net/ocaml.html"
+SRC_URI="ftp://quatramaran.ens.fr/pub/ara/ocamldsort/${P}.tar.gz"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/ocaml-3.12:=
+ dev-ml/camlp4:="
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ emake BINDIR="${ED}/usr/bin" MANDIR="${ED}/usr/share/man" install
+ dodoc README THANKS Changes
+}