summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-13 10:17:22 +0000
committerSam James <sam@gentoo.org>2021-03-13 15:23:11 +0000
commitf256d600cf319671ef606771f08a26e76d6ce3fd (patch)
tree2fb2d46c05fa01a017522ee9a62a4f72cb8847f8 /dev-ml/ocamlgraph
parentdev-ml/ocamlgraph: port 1.8.8 to EAPI 7 (diff)
downloadgentoo-f256d600cf319671ef606771f08a26e76d6ce3fd.tar.gz
gentoo-f256d600cf319671ef606771f08a26e76d6ce3fd.tar.bz2
gentoo-f256d600cf319671ef606771f08a26e76d6ce3fd.zip
dev-ml/ocamlgraph: drop 1.8.8-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlgraph')
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-1.8.8-r1.ebuild58
1 files changed, 0 insertions, 58 deletions
diff --git a/dev-ml/ocamlgraph/ocamlgraph-1.8.8-r1.ebuild b/dev-ml/ocamlgraph/ocamlgraph-1.8.8-r1.ebuild
deleted file mode 100644
index e76a4464ef6c..000000000000
--- a/dev-ml/ocamlgraph/ocamlgraph-1.8.8-r1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit findlib
-
-DESCRIPTION="O'Caml Graph library"
-HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
-SRC_URI="http://ocamlgraph.lri.fr/download/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 x86"
-RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
- gtk? ( dev-ml/lablgtk:2=[gnomecanvas,ocamlopt?] )"
-DEPEND="${RDEPEND}
- doc? ( dev-tex/hevea dev-ml/ocamlweb )"
-IUSE="doc examples gtk +ocamlopt"
-
-src_compile() {
- emake byte
- use ocamlopt && emake opt
-
- if use doc; then
- emake doc
- fi
-
- if use gtk; then
- emake OCAMLBEST=$(usex ocamlopt opt byte) viewer dgraph editor
- fi
-}
-
-src_install() {
- findlib_src_preinst
- use ocamlopt || export WANT_OCAMLOPT=no
- use gtk && export WANT_GTK=yes
- emake install-findlib
-
- if use gtk ; then
- local ext=byte
- use ocamlopt && ext=opt
- newbin dgraph/dgraph.${ext} ${PN}-dgraph
- newbin editor/editor.${ext} ${PN}-editor
- newbin view_graph/viewgraph.${ext} ${PN}-viewgraph
- fi
-
- dodoc README.adoc CREDITS FAQ CHANGES
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- if use doc; then
- docinto html
- dodoc doc/*
- fi
-}