summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-12 21:34:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-13 09:15:54 +0100
commitff872a08294f8fb2215270e639614a2fed30073e (patch)
treedc44a453b86c938192d4c66eb41f379cf6be0055 /dev-ml/ocsigen-start/ocsigen-start-9999.ebuild
parentdev-ml/ocaml-cstruct: bump to 2.3.1 (diff)
downloadgentoo-ff872a08294f8fb2215270e639614a2fed30073e.tar.gz
gentoo-ff872a08294f8fb2215270e639614a2fed30073e.tar.bz2
gentoo-ff872a08294f8fb2215270e639614a2fed30073e.zip
dev-ml/ocsigen-start: initial import; ebuild by me
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/ocsigen-start/ocsigen-start-9999.ebuild')
-rw-r--r--dev-ml/ocsigen-start/ocsigen-start-9999.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/ocsigen-start/ocsigen-start-9999.ebuild b/dev-ml/ocsigen-start/ocsigen-start-9999.ebuild
new file mode 100644
index 000000000000..3439208e10f2
--- /dev/null
+++ b/dev-ml/ocsigen-start/ocsigen-start-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="Eliom Base Application with users, (pre)registration, notifications, etc."
+HOMEPAGE="https://github.com/ocsigen/ocsigen-start"
+
+LICENSE="LGPL-3"
+SLOT="0/${PV}"
+IUSE=""
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ocsigen-start"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ocsigen-start/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RDEPEND="dev-lang/ocaml:=
+ dev-ml/pgocaml:=
+ dev-ml/macaque:=
+ dev-ml/ocaml-safepass:=
+ dev-ml/eliom:=
+ dev-ml/ocsigen-toolkit:=
+ dev-ml/ppx_deriving:=
+ dev-ml/yojson:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/magick.patch"
+}
+
+src_install() {
+ findlib_src_preinst
+ DESTDIR="${ED}" OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install
+ dodoc README.md
+}