summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-26 13:19:45 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-26 14:03:10 +0200
commitf03d3633119870c103f63b484335861f64621ad0 (patch)
treeb4c90864f9cfab6765305dc566da31886a833883 /dev-ml/opam-file-format
parentdev-ml/alcotest: bump to 0.8.2 (diff)
downloadgentoo-f03d3633119870c103f63b484335861f64621ad0.tar.gz
gentoo-f03d3633119870c103f63b484335861f64621ad0.tar.bz2
gentoo-f03d3633119870c103f63b484335861f64621ad0.zip
dev-ml/opam-file-format: initial import
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ml/opam-file-format')
-rw-r--r--dev-ml/opam-file-format/Manifest1
-rw-r--r--dev-ml/opam-file-format/metadata.xml11
-rw-r--r--dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild29
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/opam-file-format/Manifest b/dev-ml/opam-file-format/Manifest
new file mode 100644
index 000000000000..137c7f03a64a
--- /dev/null
+++ b/dev-ml/opam-file-format/Manifest
@@ -0,0 +1 @@
+DIST opam-file-format-2.0.0_beta3.tar.gz 7654 SHA256 522773503b30ff755d04c4e11efb4657e21ac59499da270ef8040d88b4371b59 SHA512 7f4989711e4dc183086b6dccc512ecfe78bfbbd98af954560d5a2c945b8b32416f3a01902203ef78932451cd99a5c1b1571edf70581bd14a2a94e32f5d4dd818 WHIRLPOOL fef711e436ca84312a3054694e8bcb0eb75011b750f8ca1cf31fa77e11d232427f4ee03dde0459cdbd9b9ae607542f0c9e35de9eddf9b63a62e858f243ed395a
diff --git a/dev-ml/opam-file-format/metadata.xml b/dev-ml/opam-file-format/metadata.xml
new file mode 100644
index 000000000000..6c62d17c464e
--- /dev/null
+++ b/dev-ml/opam-file-format/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam-file-format</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild b/dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild
new file mode 100644
index 000000000000..e932f300db77
--- /dev/null
+++ b/dev-ml/opam-file-format/opam-file-format-2.0.0_beta3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+MY_PV="${PV/_beta/-beta}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+DESCRIPTION="Parser and printer for the opam file syntax"
+HOMEPAGE="https://github.com/ocaml/opam-file-format"
+SRC_URI="https://github.com/ocaml/opam-file-format/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="dev-lang/ocaml:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake byte $(usex ocamlopt native "")
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" LIBDIR="$(ocamlc -where)" install
+}