summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-06 03:35:38 +0000
committerSam James <sam@gentoo.org>2021-11-06 03:35:38 +0000
commit39bfd96694d31fd78dff9e396fb78dbd21996752 (patch)
tree75ba5506f58d21c86577cbaa53c307a40c9b1a72 /dev-ml/opam-format
parentdev-ml/opam-client: add 2.1.1 (diff)
downloadgentoo-39bfd96694d31fd78dff9e396fb78dbd21996752.tar.gz
gentoo-39bfd96694d31fd78dff9e396fb78dbd21996752.tar.bz2
gentoo-39bfd96694d31fd78dff9e396fb78dbd21996752.zip
dev-ml/opam-format: add 2.1.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/opam-format')
-rw-r--r--dev-ml/opam-format/Manifest1
-rw-r--r--dev-ml/opam-format/opam-format-2.1.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/opam-format/Manifest b/dev-ml/opam-format/Manifest
index ed498336536d..f220f1c24723 100644
--- a/dev-ml/opam-format/Manifest
+++ b/dev-ml/opam-format/Manifest
@@ -3,3 +3,4 @@ DIST opam-2.0.8.tar.gz 643221 BLAKE2B 66510a18285f315fe95665e8ba2f334dd44211c716
DIST opam-2.0.9.tar.gz 644429 BLAKE2B d96ee79685a8ee8ff82c7570a747c80e38d86e513736a27904a4e471d1eaf432db72998251ac786cb8fbf1ad425fff42b772c5d26934e0929aae75c0946d4659 SHA512 0d8ee19ac0f3df9de4fd9cfa8daab1f7228f090f5e2e7e26bedf24d8c2ab377aade95048f2d7cd9ee9dbbe738729e26dc99f41f730fa2252df74953362464a22
DIST opam-2.1.0-dose3-6.patch.xz 5896 BLAKE2B f605064ebae7d327895729962a345a3c679519895aa2568f0c2d199d4ba9d6ae948a4fc418cfd26cc65079eb6ef3545f24a35e08c969d215529664a80d0c9147 SHA512 e00da74d7baef62319e884e3a05112bcf86a02d887c274bd15fb0d15bb8198e9a37a421f388bec3fce198e7a1b4d37024b18609dc65978c6ee8a7889df9bd608
DIST opam-2.1.0.tar.gz 825966 BLAKE2B 42ab8ad2825e4e167618ece7bd2ce77ff055d584039fe2f644fa1c3e99d175cc7047f32bda53599af4fb177d844970883125cebca823024d1bc43a34857f20c5 SHA512 c0060e609c49a12dc8f64accef990aa593db818b72df3984fb9b4b22d8678b46c515916c84134a62dab614c716b61788eadc954d295f32c1f27d38aec22b3edf
+DIST opam-2.1.1.tar.gz 818555 BLAKE2B 0f3e94c723774c38a5ad553f58fa796836eb8ef80add977a0e677df026225b5cd737409717026cfbc95388094a0434eb9ff865043c1781eba228f1499c9ab996 SHA512 fb46bc8f12e49c2da95c5f8669f55fb93710ee826827538852c3091ec2c714c082137373fa9e1ad3f53f107b1fae6c2abd0b6e5f84f7756bd3b38e57978f080e
diff --git a/dev-ml/opam-format/opam-format-2.1.1.ebuild b/dev-ml/opam-format/opam-format-2.1.1.ebuild
new file mode 100644
index 000000000000..027845d265fc
--- /dev/null
+++ b/dev-ml/opam-format/opam-format-2.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# We are opam
+OPAM_INSTALLER_DEP=" "
+inherit dune
+
+DESCRIPTION="Core libraries for opam"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/dev-ml/opam/opam-2.1.0-dose3-6.patch.xz"
+S="${WORKDIR}/opam-${PV}"
+OPAM_INSTALLER="${S}/opam-installer"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ ~dev-ml/opam-core-${PV}:=
+ dev-ml/re:=
+ dev-ml/opam-file-format:=
+ >=dev-ml/dose3-6.0:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo"
+
+PATCHES=( "${WORKDIR}"/opam-2.1.0-dose3-6.patch )
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}