summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 16:55:08 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:29 +1100
commit1fbc2ffe9cff4febc0671213d8b3a3c43b18b40e (patch)
tree7e338f49b17109fdc65aedc18333d44e992ea75d /dev-ml/opam
parentdev-ml/num: Rebuild when ocaml rebuilt, add KEYWORDS from ml-overlay. (diff)
downloadgentoo-1fbc2ffe9cff4febc0671213d8b3a3c43b18b40e.tar.gz
gentoo-1fbc2ffe9cff4febc0671213d8b3a3c43b18b40e.tar.bz2
gentoo-1fbc2ffe9cff4febc0671213d8b3a3c43b18b40e.zip
dev-ml/opam: Bump to 2.0.7
Thanks to Anton Kochkov, Christian D., xsnaut, rpansky and Benda Xu for working on this. Closes: https://bugs.gentoo.org/667334 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/opam')
-rw-r--r--dev-ml/opam/Manifest1
-rw-r--r--dev-ml/opam/metadata.xml11
-rw-r--r--dev-ml/opam/opam-2.0.7.ebuild38
3 files changed, 46 insertions, 4 deletions
diff --git a/dev-ml/opam/Manifest b/dev-ml/opam/Manifest
index 360c3df63cfc..9556c2492a09 100644
--- a/dev-ml/opam/Manifest
+++ b/dev-ml/opam/Manifest
@@ -1 +1,2 @@
DIST opam-1.3.1.tar.gz 669485 BLAKE2B e1aed54175d46f5dd9fd989e56c25657370356e26df6976c01dd089e381291fa04e25da295104f85d513010cd028276d80ebf7a4a77b38f3e089e52f4e64f43a SHA512 d075c9b2c9670d712f29bd2df34b8020da52041fa2bbef599cb54a81f63554507d78bebece45ecf668d3d1d4ed514e4ab88a1d86b64088d283bca7a8e75ae582
+DIST opam-2.0.7.tar.gz 636708 BLAKE2B 2824a5c53f4103c267f99ae10f55df740b3afcc033321e888133817c0e53c4a8fc31738338df3d6d9ff8755987e85ade4a4726be98f77b06b81ffc1476d02c3d SHA512 2ade3998a94333a5a838b55e229ab0c707e678481cae892980b986fb86f39163070a9b7d3e0e87879cd57b91a33bf6a3e15f3786c3510a635e59383782218f1d
diff --git a/dev-ml/opam/metadata.xml b/dev-ml/opam/metadata.xml
index 9d94a67c8e6c..970e090f0dfd 100644
--- a/dev-ml/opam/metadata.xml
+++ b/dev-ml/opam/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">ocaml/opam</remote-id>
- </upstream>
+ <maintainer type="person">
+ <email>gienah@gentoo.org</email>
+ <name>Mark Wright</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/opam</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-ml/opam/opam-2.0.7.ebuild b/dev-ml/opam/opam-2.0.7.ebuild
new file mode 100644
index 000000000000..4fa567962d7a
--- /dev/null
+++ b/dev-ml/opam/opam-2.0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ dev-ml/dose3:=
+ dev-ml/extlib:=
+ dev-ml/opam-client:=
+ dev-ml/opam-file-format:=
+ dev-ml/re:="
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/opam-${PV/_/-}"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}