summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-10-01 21:16:07 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-10-01 21:16:24 +0200
commit5b0573669408fbd1ff2350b90fd8dc6ce68d4fe0 (patch)
tree066367c01a13f17ed11e83da51451fe97ef72d2c /dev-ml/ounit2
parentapp-emacs/org-mode: Version bump to 9.4.6 (diff)
downloadgentoo-5b0573669408fbd1ff2350b90fd8dc6ce68d4fe0.tar.gz
gentoo-5b0573669408fbd1ff2350b90fd8dc6ce68d4fe0.tar.bz2
gentoo-5b0573669408fbd1ff2350b90fd8dc6ce68d4fe0.zip
dev-ml/ounit2: build with ocaml-4.12
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ounit2')
-rw-r--r--dev-ml/ounit2/ounit2-2.2.3.ebuild4
-rw-r--r--dev-ml/ounit2/ounit2-2.2.4.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/dev-ml/ounit2/ounit2-2.2.3.ebuild b/dev-ml/ounit2/ounit2-2.2.3.ebuild
index 40be073255c0..b53206f8e388 100644
--- a/dev-ml/ounit2/ounit2-2.2.3.ebuild
+++ b/dev-ml/ounit2/ounit2-2.2.3.ebuild
@@ -20,3 +20,7 @@ BDEPEND=""
IUSE="+ocamlopt"
S="${WORKDIR}/ounit-v${PV}"
+
+src_compile() {
+ dune build @install --profile release || die
+}
diff --git a/dev-ml/ounit2/ounit2-2.2.4.ebuild b/dev-ml/ounit2/ounit2-2.2.4.ebuild
index b67e4a2fd511..967a9daf84da 100644
--- a/dev-ml/ounit2/ounit2-2.2.4.ebuild
+++ b/dev-ml/ounit2/ounit2-2.2.4.ebuild
@@ -20,3 +20,7 @@ DEPEND="
dev-ml/stdlib-shims:=
"
RDEPEND="${DEPEND}"
+
+src_compile() {
+ dune build @install --profile release || die
+}