summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-22 11:06:17 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-22 11:06:26 +0100
commitec8a5478b8b65138b052afdd20a52254e0db707b (patch)
tree464b14d8c341306f6ba580ae190fc769ba3b54f2 /dev-ml/pgocaml/pgocaml-2.3.ebuild
parentdev-cpp/eigen: Drop -g2 from build flags (diff)
downloadgentoo-ec8a5478b8b65138b052afdd20a52254e0db707b.tar.gz
gentoo-ec8a5478b8b65138b052afdd20a52254e0db707b.tar.bz2
gentoo-ec8a5478b8b65138b052afdd20a52254e0db707b.zip
dev-ml/pgocaml: bump to 2.3
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/pgocaml/pgocaml-2.3.ebuild')
-rw-r--r--dev-ml/pgocaml/pgocaml-2.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/pgocaml/pgocaml-2.3.ebuild b/dev-ml/pgocaml/pgocaml-2.3.ebuild
new file mode 100644
index 000000000000..c9e22b4b42ac
--- /dev/null
+++ b/dev-ml/pgocaml/pgocaml-2.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="PG'OCaml is a set of OCaml bindings for the PostgreSQL database"
+HOMEPAGE="http://pgocaml.forge.ocamlcore.org/"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1597/${P}.tgz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlp4 doc"
+
+DEPEND="dev-ml/calendar:=
+ dev-ml/csv:=
+ dev-ml/pcre-ocaml:=
+ camlp4? ( dev-ml/camlp4:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "README.md" "CHANGELOG.txt"
+ "doc/BUGS.txt" "doc/CONTRIBUTORS.txt"
+ "doc/HOW_IT_WORKS.txt" "doc/PROFILING.txt"
+ )
+
+src_configure() {
+ oasis_configure_opts="$(use_enable camlp4 p4)" oasis_src_configure
+}