summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-07-13 18:53:06 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-07-13 18:53:06 +0200
commitb33f613fe199bc5712a218e23890ea74588a0b44 (patch)
tree898aee54fc16ef109e739e15ce8958f5b8b8c20b /dev-ml/ppx_expect
parentgames-puzzle/neverball: EAPI 6->7, fix prefix and AbsoluteSymlink (diff)
downloadgentoo-b33f613fe199bc5712a218e23890ea74588a0b44.tar.gz
gentoo-b33f613fe199bc5712a218e23890ea74588a0b44.tar.bz2
gentoo-b33f613fe199bc5712a218e23890ea74588a0b44.zip
dev-ml/ppx_expect: bump to 0.14.1
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_expect')
-rw-r--r--dev-ml/ppx_expect/Manifest1
-rw-r--r--dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ppx_expect/Manifest b/dev-ml/ppx_expect/Manifest
index cf96d5df7d22..b6fc1335e86c 100644
--- a/dev-ml/ppx_expect/Manifest
+++ b/dev-ml/ppx_expect/Manifest
@@ -1 +1,2 @@
DIST ppx_expect-0.14.0.tar.gz 45661 BLAKE2B 0cba3840743d45f0f11936f090319aab3237c7a14389eb6d035a3b7cdac91e0b169c3ed84407e1bb01a00738bf97b62dba313965e93a2177388666764fe5854b SHA512 7de5d84640d16101d38140b5f621301c9935e3161a7c7d978373940be92fa7f14cad429e79eec294a20d1f379e969cf3c25d15810f1a4d3ad1bb8ba0eb7d7109
+DIST ppx_expect-0.14.1.tar.gz 45699 BLAKE2B b52d579d92156344ff44d30c88603840eb7d6a0d346de49fcbc01ef16fe3c33e664486de4cb2d09f74e853e39b9a01778e7e0f489497fdd34fc9582d895a0d3b SHA512 fd98e79d5b3bb935b2a4077a07894c159b48e142268c2e30ebff2cbfecc92266b454be69f5080b315eefa9184372e5e5248bd8a3b2b9d6cad59e2d517c94bd02
diff --git a/dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild b/dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild
new file mode 100644
index 000000000000..9d7682d713fc
--- /dev/null
+++ b/dev-ml/ppx_expect/ppx_expect-0.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Cram like framework for OCaml"
+HOMEPAGE="https://github.com/janestreet/ppx_expect"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ >=dev-ml/ppx_here-0.14.0:=
+ >=dev-ml/ppx_inline_test-0.14.1:=
+ >=dev-ml/stdio-0.14.0:=
+ >=dev-ml/ppxlib-0.18.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+ dev-ml/re:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ test? (
+ dev-ml/ppx_jane
+ )"
+# https://bugs.gentoo.org/749291#c2
+RESTRICT=test