summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 19:26:25 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commita1b185bcdff1f6cc98ae6d143f2e91aafde80ed5 (patch)
tree77a395d639dbaaceabc655549e75b1c16d710b80 /dev-ml/ppx_let/ppx_let-113.24.00.ebuild
parentdev-ml/ppx_pipebang: initial import; ebuild by me (diff)
downloadgentoo-a1b185bcdff1f6cc98ae6d143f2e91aafde80ed5.tar.gz
gentoo-a1b185bcdff1f6cc98ae6d143f2e91aafde80ed5.tar.bz2
gentoo-a1b185bcdff1f6cc98ae6d143f2e91aafde80ed5.zip
dev-ml/ppx_let: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_let/ppx_let-113.24.00.ebuild')
-rw-r--r--dev-ml/ppx_let/ppx_let-113.24.00.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/ppx_let/ppx_let-113.24.00.ebuild b/dev-ml/ppx_let/ppx_let-113.24.00.ebuild
new file mode 100644
index 000000000000..b451b5325ed8
--- /dev/null
+++ b/dev-ml/ppx_let/ppx_let-113.24.00.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Monadic let-bindings"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc README.md
+}