summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-09 18:31:10 +0000
committerSam James <sam@gentoo.org>2021-02-09 18:31:22 +0000
commit8fba56ffe31ff29f1f4bcb9cd35d594894befd7b (patch)
tree8b88daa56b9f01c4b05bf5f36ed8fc8eb88509cd /dev-ml/ppx_sexp_conv
parentapp-shells/pdmenu: Remove old (diff)
downloadgentoo-8fba56ffe31ff29f1f4bcb9cd35d594894befd7b.tar.gz
gentoo-8fba56ffe31ff29f1f4bcb9cd35d594894befd7b.tar.bz2
gentoo-8fba56ffe31ff29f1f4bcb9cd35d594894befd7b.zip
dev-ml/ppx_sexp_conv: bump to 0.14.2, upper bound on ppxlib
* No functional change with the bump as it applies the patch we already had. But we're doing the bump anyway because it looks nicer than a revbump (and avoids "new version" noise) for... * Add upper-bound on dev-ml/ppxlib as we're broken with >0.20.0. Closes: https://bugs.gentoo.org/769536 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_sexp_conv')
-rw-r--r--dev-ml/ppx_sexp_conv/Manifest1
-rw-r--r--dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_conv/Manifest b/dev-ml/ppx_sexp_conv/Manifest
index 3c751982c3d5..aefbf2ef1839 100644
--- a/dev-ml/ppx_sexp_conv/Manifest
+++ b/dev-ml/ppx_sexp_conv/Manifest
@@ -1,2 +1,3 @@
DIST ppx_sexp_conv-0.14.1.tar.gz 49857 BLAKE2B ede55963d995917bd0c4a1464b58f8584ec6be4793df706fd3be96670fe685aba82459f9a1e4c6117c594953a3f23c502cc609f1069d482d24278baf7ed87ed5 SHA512 5018abe07300f67cb2c8b8cd8242403a91ac6b7fda13fe43060b3b09635082a7ad45858c7c6442a5fcae2b6d7d398a03eec16cfcbc5fd59f7f3f5c5fd1ad56f9
+DIST ppx_sexp_conv-0.14.2.tar.gz 49876 BLAKE2B 32109eb6300894156f91721a1c74e94803106cf8a9a9326bf815d3094e166ce34b19f3d28b770d381ca3ce32227a80b15baa61e6f9c2d0082c47b87678c0f239 SHA512 d0121770030da142fd559b5f8d52d4a029d032c5ac9c79bf235190e0aaff58e5cce0a5ca5f198ca8a112e0970ca27ab18d4f201376ca6b799b91d71deb915f25
DIST ppx_sexp_conv-0.9.0.tar.gz 28000 BLAKE2B 2536d3ddbd4ee83baf9eade208983ce9856318079e29da9858838c985b904a7e2e1c6e3ea06bd1360cc17e619f1e952634554e89b294dd00981934679b384c3f SHA512 af3d28a3cdb7c796549a2598c218f69a69d58da715ef2d16077c3adeb22823fa7bec6bc0d8cb6caaf2a0adb56dfcb39d667975959251fb310b69d6abe8302845
diff --git a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild
new file mode 100644
index 000000000000..0779d1b88a06
--- /dev/null
+++ b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Support Library for type-driven code generators"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_conv"
+SRC_URI="https://github.com/janestreet/ppx_sexp_conv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+
+# Upper bound on ppxlib for bug #769536
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ dev-ml/findlib:=
+ >=dev-ml/ppxlib-0.18.0:=
+ <=dev-ml/ppxlib-0.20.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+ dev-ml/sexplib0:=
+"
+RDEPEND="${DEPEND}"