summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-15 04:03:53 +0100
committerSam James <sam@gentoo.org>2021-10-15 04:03:53 +0100
commitc34de73d3495b34471b3563c7355efe353b0b317 (patch)
tree96414d54db679fcd7b7f7e67cc9776a5c04ea03b /dev-ml/ppxlib/ppxlib-0.20.0-r1.ebuild
parentdev-ml/ppx_expect: tidy ebuild (diff)
downloadgentoo-c34de73d3495b34471b3563c7355efe353b0b317.tar.gz
gentoo-c34de73d3495b34471b3563c7355efe353b0b317.tar.bz2
gentoo-c34de73d3495b34471b3563c7355efe353b0b317.zip
dev-ml/ppxlib: fix dependencies
Closes: https://bugs.gentoo.org/818151 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ppxlib/ppxlib-0.20.0-r1.ebuild')
-rw-r--r--dev-ml/ppxlib/ppxlib-0.20.0-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/ppxlib/ppxlib-0.20.0-r1.ebuild b/dev-ml/ppxlib/ppxlib-0.20.0-r1.ebuild
new file mode 100644
index 000000000000..d1dbfa8de952
--- /dev/null
+++ b/dev-ml/ppxlib/ppxlib-0.20.0-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+# Note that new "major" versions may change which OCaml version they support
+# See:
+# https://github.com/ocaml-ppx/ppxlib/issues/243
+# https://github.com/ocaml-ppx/ppxlib/issues/232
+
+DESCRIPTION="Base library and tools for ppx rewriters"
+HOMEPAGE="https://github.com/ocaml-ppx/ppxlib"
+SRC_URI="https://github.com/ocaml-ppx/ppxlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/base-0.11.0:=
+ dev-ml/findlib:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.1.0:=
+ dev-ml/sexplib0:=
+ dev-ml/stdlib-shims:=
+ >=dev-ml/ppx_derivers-1.2.1:=
+ >=dev-ml/stdio-0.11.0:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/cinaps:= )"