summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-17 09:14:51 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-17 10:46:57 +0100
commit4045b7212a63f6887586749ca84050b22c2ffbc3 (patch)
tree6eb5005461e6fdcc81349df360419e852919f74c /dev-ml/react/react-1.2.1.ebuild
parentdev-ml/xmlm: Bump to 1.3.0 (diff)
downloadgentoo-4045b7212a63f6887586749ca84050b22c2ffbc3.tar.gz
gentoo-4045b7212a63f6887586749ca84050b22c2ffbc3.tar.bz2
gentoo-4045b7212a63f6887586749ca84050b22c2ffbc3.zip
dev-ml/react: Bump to 1.2.1
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml/react/react-1.2.1.ebuild')
-rw-r--r--dev-ml/react/react-1.2.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/react/react-1.2.1.ebuild b/dev-ml/react/react-1.2.1.ebuild
new file mode 100644
index 000000000000..fe35d7192846
--- /dev/null
+++ b/dev-ml/react/react-1.2.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+DESCRIPTION="OCaml module for functional reactive programming"
+HOMEPAGE="http://erratique.ch/software/react https://github.com/dbuenzli/react"
+SRC_URI="http://erratique.ch/software/react/releases/${P}.tbz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86-fbsd"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ocaml-3.12:="
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/opam
+ >=dev-ml/topkg-0.9
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test 'true' 'false') \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ || die
+ dodoc CHANGES.md README.md TODO.md
+}