summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-14 00:02:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-14 00:09:34 +0200
commitcf17060c135e0055c350510ab641b337b3d082f2 (patch)
tree51de703461435b810631f95128a861368bd7cebc /dev-ml/sedlex
parentdev-ml/ocaml-cstruct: bump to 3.1.0 (diff)
downloadgentoo-cf17060c135e0055c350510ab641b337b3d082f2.tar.gz
gentoo-cf17060c135e0055c350510ab641b337b3d082f2.tar.bz2
gentoo-cf17060c135e0055c350510ab641b337b3d082f2.zip
dev-ml/sedlex: bump to 1.99.4
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/sedlex')
-rw-r--r--dev-ml/sedlex/Manifest1
-rw-r--r--dev-ml/sedlex/sedlex-1.99.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/sedlex/Manifest b/dev-ml/sedlex/Manifest
index b117235a48b8..71993db0a784 100644
--- a/dev-ml/sedlex/Manifest
+++ b/dev-ml/sedlex/Manifest
@@ -1 +1,2 @@
DIST sedlex-1.99.3.tar.gz 58236 SHA256 54a1c32e5505dc081b3f231f21501ebebddcd50ee097e9c163ba347855b953fb SHA512 d0359a4c3f4d9efe51fa79405ae79f20ab64949838acbac475a9bcb7f42e0b972e66429eca2063fda6ae6af04475dbf29a331cf005f3338e7fc130afab477392 WHIRLPOOL f64bed9952ad93eff6512fd28b7ab5f343dd42d1ae3aa3851138976672679197a67ac094916590251079c0346d3d4ecc999f8289bb2a80ee3fefca5c1b401431
+DIST sedlex-1.99.4.tar.gz 59359 SHA256 3ba074870ccffffd16a11b205373985012395c020dd19c1ca5f9811a91c263c7 SHA512 83bddb03e25b015bc71fb59e3b0e0e097e899c681c8033663c17936f28fde8599a82eaab9c26eafd645c401c106e65fcf173d9fb889eb8999eb1b064ff8b6149 WHIRLPOOL ed2f8e7e7822d143619c67b72a24f78a90ce9baa9e7ea82eacaf2ec7cd9911422bc696c6d60e58e47ebbc5791be963c639c655b3cd5a88354af3782df9abbcf1
diff --git a/dev-ml/sedlex/sedlex-1.99.4.ebuild b/dev-ml/sedlex/sedlex-1.99.4.ebuild
new file mode 100644
index 000000000000..b2a4d281ef05
--- /dev/null
+++ b/dev-ml/sedlex/sedlex-1.99.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="An OCaml lexer generator for Unicode"
+HOMEPAGE="https://github.com/alainfrisch/sedlex"
+SRC_URI="https://github.com/alainfrisch/sedlex/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/gen:=[ocamlopt(+)?]
+ dev-ml/ppx_tools_versioned:=[ocamlopt(+)?]
+ dev-ml/ocaml-migrate-parsetree:=[ocamlopt(+)?]
+"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake all
+ use ocamlopt && emake opt
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_preinst
+ if use ocamlopt; then
+ emake install
+ else
+ emake install_byteonly
+ fi
+ dodoc CHANGES README.md
+}