summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 19:42:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commit7fd3edffff3608ef1bed6c478b00c030d2cb400a (patch)
tree8d6cdbf80c10fd4726c19f88a5f0d55508aa5bd0 /dev-ml/typerep_extended/typerep_extended-113.24.00.ebuild
parentdev-ml/core_kernel: bump to 113.24.00 (diff)
downloadgentoo-7fd3edffff3608ef1bed6c478b00c030d2cb400a.tar.gz
gentoo-7fd3edffff3608ef1bed6c478b00c030d2cb400a.tar.bz2
gentoo-7fd3edffff3608ef1bed6c478b00c030d2cb400a.zip
dev-ml/typerep_extended: bump to 113.24.00
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/typerep_extended/typerep_extended-113.24.00.ebuild')
-rw-r--r--dev-ml/typerep_extended/typerep_extended-113.24.00.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-ml/typerep_extended/typerep_extended-113.24.00.ebuild b/dev-ml/typerep_extended/typerep_extended-113.24.00.ebuild
new file mode 100644
index 000000000000..c2e7488f0cbb
--- /dev/null
+++ b/dev-ml/typerep_extended/typerep_extended-113.24.00.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Runtime types for OCaml (Extended)"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ >=dev-ml/typerep-112.17.00:=
+ dev-ml/sexplib:=
+ dev-ml/bin-prot:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_bin_prot:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_sexp_conv:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/ppx_typerep_conv:="
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}