summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-05 09:47:33 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-05 09:47:33 +0100
commit319246f68987611f4e3287937719ee1ad89096c5 (patch)
tree18bf8a1f934c797b766fb01433ede10abe5d8064 /dev-ml/utop/utop-1.18.1.ebuild
parentdev-ml/zarith: Bump to 1.4. (diff)
downloadgentoo-319246f68987611f4e3287937719ee1ad89096c5.tar.gz
gentoo-319246f68987611f4e3287937719ee1ad89096c5.tar.bz2
gentoo-319246f68987611f4e3287937719ee1ad89096c5.zip
dev-ml/utop: Bump to 1.18.1
Package-Manager: portage-2.2.24 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/utop/utop-1.18.1.ebuild')
-rw-r--r--dev-ml/utop/utop-1.18.1.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/utop/utop-1.18.1.ebuild b/dev-ml/utop/utop-1.18.1.ebuild
new file mode 100644
index 000000000000..8da80ebddb9a
--- /dev/null
+++ b/dev-ml/utop/utop-1.18.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+inherit oasis elisp-common
+
+DESCRIPTION="A new toplevel for OCaml with completion and colorization"
+HOMEPAGE="https://github.com/diml/utop"
+SRC_URI="https://github.com/diml/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlp4 emacs"
+
+DEPEND=">=dev-ml/lwt-2.4.0:=[react]
+ >=dev-ml/lambda-term-1.2:=
+ >=dev-ml/zed-1.2:=
+ >=dev-ml/cppo-1.0.1:=
+ emacs? ( virtual/emacs )
+ camlp4? ( || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 ) )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES.md" "README.md" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "s/(\"utop.el.*)//" setup.ml
+}
+
+src_configure() {
+ oasis_configure_opts="$(use_enable camlp4)" \
+ oasis_src_configure
+}
+src_compile() {
+ oasis_src_compile
+ if use emacs; then
+ elisp-compile src/top/*.el
+ fi
+}
+
+src_install() {
+ oasis_src_install
+ if use emacs; then
+ elisp-install "${PN}" src/top/*.el src/top/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}