summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-04 12:31:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-04 12:32:34 +0100
commit4cb4f3396831a26100eeb5815b606f15c9a2fc73 (patch)
tree8ad4277a2d6e9e7c8bdecddf8abde3c39915ba5d /dev-ml/utop/utop-1.18.2.ebuild
parentmedia-sound/teamspeak-server-bin: version bump 3.0.12.2 bug #576022 (diff)
downloadgentoo-4cb4f3396831a26100eeb5815b606f15c9a2fc73.tar.gz
gentoo-4cb4f3396831a26100eeb5815b606f15c9a2fc73.tar.bz2
gentoo-4cb4f3396831a26100eeb5815b606f15c9a2fc73.zip
dev-ml/utop: bump to 1.18.2
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/utop/utop-1.18.2.ebuild')
-rw-r--r--dev-ml/utop/utop-1.18.2.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/dev-ml/utop/utop-1.18.2.ebuild b/dev-ml/utop/utop-1.18.2.ebuild
new file mode 100644
index 000000000000..8da80ebddb9a
--- /dev/null
+++ b/dev-ml/utop/utop-1.18.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+inherit oasis elisp-common
+
+DESCRIPTION="A new toplevel for OCaml with completion and colorization"
+HOMEPAGE="https://github.com/diml/utop"
+SRC_URI="https://github.com/diml/utop/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="camlp4 emacs"
+
+DEPEND=">=dev-ml/lwt-2.4.0:=[react]
+ >=dev-ml/lambda-term-1.2:=
+ >=dev-ml/zed-1.2:=
+ >=dev-ml/cppo-1.0.1:=
+ emacs? ( virtual/emacs )
+ camlp4? ( || ( dev-ml/camlp4:= <dev-lang/ocaml-4.02.0 ) )"
+RDEPEND="${DEPEND}"
+
+DOCS=( "CHANGES.md" "README.md" )
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ sed -i "s/(\"utop.el.*)//" setup.ml
+}
+
+src_configure() {
+ oasis_configure_opts="$(use_enable camlp4)" \
+ oasis_src_configure
+}
+src_compile() {
+ oasis_src_compile
+ if use emacs; then
+ elisp-compile src/top/*.el
+ fi
+}
+
+src_install() {
+ oasis_src_install
+ if use emacs; then
+ elisp-install "${PN}" src/top/*.el src/top/*.elc || die
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}