summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-09-19 20:30:35 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-09-19 20:59:23 +0200
commit89d5e44368c71b5747c011e43a9b78efcf6a0b8c (patch)
treed061690850c1f6e8418d9f6fb343ee671a205718 /dev-ml/uuidm
parentdev-util/tree-sitter-cli: Keyword 0.20.7 ppc64, #871528 (diff)
downloadgentoo-89d5e44368c71b5747c011e43a9b78efcf6a0b8c.tar.gz
gentoo-89d5e44368c71b5747c011e43a9b78efcf6a0b8c.tar.bz2
gentoo-89d5e44368c71b5747c011e43a9b78efcf6a0b8c.zip
dev-ml/uuidm: bump to 0.9.8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/uuidm')
-rw-r--r--dev-ml/uuidm/Manifest1
-rw-r--r--dev-ml/uuidm/uuidm-0.9.8.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ml/uuidm/Manifest b/dev-ml/uuidm/Manifest
index 135e673ee5bc..c59ce5b27bed 100644
--- a/dev-ml/uuidm/Manifest
+++ b/dev-ml/uuidm/Manifest
@@ -1 +1,2 @@
DIST uuidm-0.9.7.tar.gz 9258 BLAKE2B 37867ee562fcf5c44e0f40df53707a5066d74c185037049b4b4034326e1efa93543d518f6c9d5d27e9663f18d824f951d27952c844e1169d951abb7b91caeebb SHA512 7048e467bbd9eefd19ca057caadcc8f634d4eae7642665a84df88f726df3fb849085613d75a485272b0d0e19c9041c560a8c864e780dbed29ff68e3cfa8ba3d4
+DIST uuidm-0.9.8.tar.gz 10079 BLAKE2B d441380dc3a4e326f777b2f9ed313cf3c27213ca5e1a02197fff40e3422df12a3451badf732b3dfae00eb8feb9fc72c137c9d5b0c20f7df4c17494d903e1b65c SHA512 af3ca7faa7eba04c4078ddc43eee6cd8a1e210127e18d1d97fbdd00b98729caab0b52a6a05c090061e05656ef321c5e07bab13113e656c5c8b5285f193f070a8
diff --git a/dev-ml/uuidm/uuidm-0.9.8.ebuild b/dev-ml/uuidm/uuidm-0.9.8.ebuild
new file mode 100644
index 000000000000..154a7d23edf4
--- /dev/null
+++ b/dev-ml/uuidm/uuidm-0.9.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit opam
+
+DESCRIPTION="Universally unique identifiers (UUIDs) for OCaml"
+HOMEPAGE="https://github.com/dbuenzli/uuidm/"
+SRC_URI="https://github.com/dbuenzli/uuidm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="
+ dev-ml/findlib[ocamlopt=]
+ dev-ml/ocamlbuild[ocamlopt=]
+ dev-ml/topkg
+"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}