summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-19 15:53:24 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-19 16:01:21 +0100
commitd1a2e1090a19bba04aeef0136648b7336b5081f8 (patch)
tree0c825fa9d57b6b35d5e0c4e4c2f82876666b9972 /dev-ml/yojson/yojson-1.3.0.ebuild
parentsci-mathematics/fricas: update depend on sbcl to <=1.3.0 (diff)
downloadgentoo-d1a2e1090a19bba04aeef0136648b7336b5081f8.tar.gz
gentoo-d1a2e1090a19bba04aeef0136648b7336b5081f8.tar.bz2
gentoo-d1a2e1090a19bba04aeef0136648b7336b5081f8.zip
dev-ml/yojson: bump to 1.3.0
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/yojson/yojson-1.3.0.ebuild')
-rw-r--r--dev-ml/yojson/yojson-1.3.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-ml/yojson/yojson-1.3.0.ebuild b/dev-ml/yojson/yojson-1.3.0.ebuild
new file mode 100644
index 000000000000..cab42fda852b
--- /dev/null
+++ b/dev-ml/yojson/yojson-1.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="JSON parsing and pretty-printing library for OCaml"
+HOMEPAGE="http://mjambon.com/yojson.html"
+SRC_URI="https://github.com/mjambon/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+LICENSE="BSD"
+KEYWORDS="~amd64"
+IUSE="examples"
+
+RDEPEND=">=dev-lang/ocaml-3.11:=[ocamlopt]
+ dev-ml/easy-format:=[ocamlopt]
+ dev-ml/biniou:=[ocamlopt]
+"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+"
+
+src_compile() {
+ emake -j1
+}
+
+src_install() {
+ dodir /usr/bin
+ findlib_src_install BINDIR="${ED}"/usr/bin
+ dodoc README.md Changes
+ if use examples ; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}