summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-07 21:28:37 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-07 21:52:34 +0100
commit03ec5e0a93aef83ea87b9dc666a0bd7f954ac8d4 (patch)
tree95cd7e1c054cb6c0e136eab6b14ea36b43be85c5 /dev-ml
parentwww-client/microsoft-edge-beta: remove old (diff)
downloadgentoo-03ec5e0a93aef83ea87b9dc666a0bd7f954ac8d4.tar.gz
gentoo-03ec5e0a93aef83ea87b9dc666a0bd7f954ac8d4.tar.bz2
gentoo-03ec5e0a93aef83ea87b9dc666a0bd7f954ac8d4.zip
dev-ml/ocaml-process: fix a spelling mistake in make opts
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-process/ocaml-process-0.2.1-r1.ebuild (renamed from dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild)16
1 files changed, 8 insertions, 8 deletions
diff --git a/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild b/dev-ml/ocaml-process/ocaml-process-0.2.1-r1.ebuild
index 2979a23b9a6f..591c51a1167c 100644
--- a/dev-ml/ocaml-process/ocaml-process-0.2.1.ebuild
+++ b/dev-ml/ocaml-process/ocaml-process-0.2.1-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit findlib
@@ -27,12 +27,12 @@ src_compile() {
emake TARGETS="${exts}"
}
-src_install() {
- local archive=''
- use ocamlopt && archive='_build/lib/process.a'
- findlib_src_install TARGETS="${exts}" ARCHIVES=${archives}
-}
-
src_test() {
emake -j1 TARGETS=${exts} test
}
+
+src_install() {
+ local archives=''
+ use ocamlopt && archives='_build/lib/process.a'
+ findlib_src_install TARGETS="${exts}" ARCHIVES="${archives}"
+}