summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2020-01-07 15:54:51 -0500
committerJason A. Donenfeld <zx2c4@gentoo.org>2020-01-07 16:00:55 -0500
commit0849f2d4192c441bdd07a752b02c780b5a8b3022 (patch)
tree8cfe98401510ce9ce72f96da82759ce12dc30b03 /dev-ml
parentdev-libs/nss: Version bump to 3.49 (diff)
downloadgentoo-0849f2d4192c441bdd07a752b02c780b5a8b3022.tar.gz
gentoo-0849f2d4192c441bdd07a752b02c780b5a8b3022.tar.bz2
gentoo-0849f2d4192c441bdd07a752b02c780b5a8b3022.zip
dev-ml/num: add for newer ocaml + coq
Fixes: https://bugs.gentoo.org/704928 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/num/Manifest1
-rw-r--r--dev-ml/num/metadata.xml5
-rw-r--r--dev-ml/num/num-1.3.ebuild24
3 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/num/Manifest b/dev-ml/num/Manifest
new file mode 100644
index 000000000000..944b4079b5a1
--- /dev/null
+++ b/dev-ml/num/Manifest
@@ -0,0 +1 @@
+DIST num-1.3.tar.gz 66251 BLAKE2B d6fde246693c8aef3b881a4ebc2b601392e0f0bf561dc4f4d32a5e1f835a5186deba3ffa77c88c6c05cd6e837dc836567fcabffefae99ce1ccae94e1bdfc849a SHA512 c88310f8c45700990095e6b2e9abf24c27347711b9abfd1dde75e540fbbfc6a365e6713bd69f66009af305728fcb36dc61eb37fdd0be7d73824b0e92fbe8c031
diff --git a/dev-ml/num/metadata.xml b/dev-ml/num/metadata.xml
new file mode 100644
index 000000000000..bca0744b282e
--- /dev/null
+++ b/dev-ml/num/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/dev-ml/num/num-1.3.ebuild b/dev-ml/num/num-1.3.ebuild
new file mode 100644
index 000000000000..930c8cb51663
--- /dev/null
+++ b/dev-ml/num/num-1.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib findlib
+
+DESCRIPTION="Library for arbitrary-precision integer and rational arithmetic"
+HOMEPAGE="https://github.com/ocaml/num"
+SRC_URI="https://github.com/ocaml/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/ocaml"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}"
+
+src_install() {
+ findlib_src_preinst
+ OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install DESTDIR="${D}"
+}