summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2017-10-12 20:38:34 +0200
committerTupone Alfredo <tupone@gentoo.org>2017-10-12 20:38:34 +0200
commit10942bf83b1eaff5647af5f136793bcb993bd022 (patch)
treea6eeb237a6588a593eb509f7990e6545fd156126 /dev-ml
parentnet-analyzer/prometheus-node_exporter: Fix metadata.xml (diff)
downloadgentoo-10942bf83b1eaff5647af5f136793bcb993bd022.tar.gz
gentoo-10942bf83b1eaff5647af5f136793bcb993bd022.tar.bz2
gentoo-10942bf83b1eaff5647af5f136793bcb993bd022.zip
dev-ml/ocplib-simplex: Add dev-ml/ocplib-simplex-0.3
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocplib-simplex/Manifest1
-rw-r--r--dev-ml/ocplib-simplex/metadata.xml12
-rw-r--r--dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild31
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocplib-simplex/Manifest b/dev-ml/ocplib-simplex/Manifest
new file mode 100644
index 000000000000..531355b84688
--- /dev/null
+++ b/dev-ml/ocplib-simplex/Manifest
@@ -0,0 +1 @@
+DIST ocplib-simplex-0.3.tar.gz 31013 SHA256 59bf450593e2407d52029140803e0e1343d6e30d1564f65cb2b7ec9582681171 SHA512 43373deb6e921a31526c27d33808c3520b4f375caf9e5237179db0e8d84b5be3bf43e061e2d991fc6de694958c64c7ede0b258400fb921c4139664e367958630 WHIRLPOOL eb27382e3726bbdb408b41512bb7ff294a5cb6a06335c726ae2c7a197f6fe5c829cdd2f3b2cf6a0bea483e21025fea6146f571aad60c2f91f004dadec770b264
diff --git a/dev-ml/ocplib-simplex/metadata.xml b/dev-ml/ocplib-simplex/metadata.xml
new file mode 100644
index 000000000000..01c5e44dd808
--- /dev/null
+++ b/dev-ml/ocplib-simplex/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>tupone@gentoo.org</email>
+ <name>Tupone Alfredo</name>
+ </maintainer>
+ <longdescription lang="en">
+ A library implementing a simplex algorithm, in a functional style,
+ for solving systems of linear inequalities
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild b/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild
new file mode 100644
index 000000000000..cf06261cf33b
--- /dev/null
+++ b/dev-ml/ocplib-simplex/ocplib-simplex-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools findlib multilib
+
+DESCRIPTION="A library implementing a simplex algorithm"
+HOMEPAGE="https://github.com/OCamlPro-Iguernlala/ocplib-simplex"
+SRC_URI="https://github.com/OCamlPro-Iguernlala/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES.md README.md extra/simplex_invariants.txt extra/TODO.txt"
+
+src_prepare() {
+ default
+ mv configure.{in,ac} || die
+ eautoreconf
+}
+
+src_install() {
+ findlib_src_install LIBDIR="${D}"usr/"$(get_libdir)"/ocaml
+}