summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-07-15 19:42:32 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-07-15 19:42:32 +0200
commit16192c4634cd656b52153ee6f2bd46fc1920d2df (patch)
tree0094388726ac4f68007e0d40688667890ea0b20e /dev-ml
parentgames-engines/stratagus: Bump to 3.1.1 (diff)
downloadgentoo-16192c4634cd656b52153ee6f2bd46fc1920d2df.tar.gz
gentoo-16192c4634cd656b52153ee6f2bd46fc1920d2df.tar.bz2
gentoo-16192c4634cd656b52153ee6f2bd46fc1920d2df.zip
dev-ml/ocamlnet: bump to 4.1.9
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlnet/Manifest1
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-ml/ocamlnet/Manifest b/dev-ml/ocamlnet/Manifest
index ad3635f4b81d..f8c4e062ea07 100644
--- a/dev-ml/ocamlnet/Manifest
+++ b/dev-ml/ocamlnet/Manifest
@@ -1 +1,2 @@
DIST ocamlnet-4.1.8.tar.gz 4620065 BLAKE2B 8f84ce4d79de5f4a1f26d4e45f68327042b0adc22717e56eeaca03ee6371e9251c01e8736d3afe5c00a1c65ef0286d56a04c57e80377402bb19ff87955ae98d9 SHA512 e238235968b9546c60568a38e68e354378d30e7137973332dcb10da21fa775ab7b367889fc51f5bd7cb00e51582834cafe2a0c4706b0bc77a44d4571a6f22815
+DIST ocamlnet-4.1.9.tar.gz 4628747 BLAKE2B 40e41edee79ba5957d297506cdf1b907adc8d44a33f25f25b8b1a18487f5ec379fb328c86d6283f7da7cedd8d35b80809e1cd5224522d51afa3e5f2402ac8663 SHA512 a251724deb35e756c81d2d3ac836d413b659acdce6c0acf479a4fca48934ab62ad399a884197d00dbb7e7558132a56be1c8efd553c0a644d329418272f809a46
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild
new file mode 100644
index 000000000000..c0ee784e835e
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-4.1.9.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="ZLIB GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="kerberos tk httpd +ocamlopt +pcre ssl zip"
+RESTRICT="installsources strip"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+BDEPEND="
+ dev-ml/cppo
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=dev-ml/findlib-1.0
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ pcre? ( >=dev-ml/pcre-ocaml-5:= )
+ tk? ( dev-ml/labltk:= )
+ ssl? ( net-libs/gnutls:= )
+ kerberos? ( virtual/krb5 )
+ zip? ( dev-ml/camlzip:= )
+"
+DEPEND="${RDEPEND}"
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable ssl gnutls) \
+ $(ocamlnet_use_enable kerberos gssapi) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error: econf failed!"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ findlib_src_install
+}