summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-06 08:12:58 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-06 08:17:37 +0100
commit181a9b62842dfbc289d66659f3c666edd09b115d (patch)
tree7e8ea0ee635ed99dccc431da07e271db0904f435 /dev-ml
parentdev-util/cccc: Add missing MFC dialect patch and options file (diff)
downloadgentoo-181a9b62842dfbc289d66659f3c666edd09b115d.tar.gz
gentoo-181a9b62842dfbc289d66659f3c666edd09b115d.tar.bz2
gentoo-181a9b62842dfbc289d66659f3c666edd09b115d.zip
dev-ml/ocaml-cstruct: Bump to 2.3.2
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
index 23fdfee646ce..867b857168cd 100644
--- a/dev-ml/ocaml-cstruct/Manifest
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -1 +1,2 @@
DIST ocaml-cstruct-2.3.1.tar.gz 259266 SHA256 89a4f363547026de195fd84d9e842844ed6bbf4c5ab57c2fc1500741106b1797 SHA512 7dfb080f4d6f1685719ed31edd69cb5f4e484d42b28e0340dace8dd9a4742342957b67de0b10f0c4f4ccab7a80b13ddc3a26d2401cffdd232dc9581dba1da2ff WHIRLPOOL 6c41df0677217f45f13a03686e4a025da8f9edadccb5a27659cc1349bbae2f324a07d68e056f7078e4f4336d357c5558f262d0c6f4813017db0325e2b304b06e
+DIST ocaml-cstruct-2.3.2.tar.gz 259424 SHA256 16c619be7644c30227a617cea8be509460b36a6a4c8f2b45a56fec75113570e0 SHA512 7f88c37729869fbfe39c28be4c56c49ba225da7f7d4df2f962a730be2a9c70bb6099713f83e4aa53e77ac7752c415427e86d95a42abcb6c280a79ae9931cdeee WHIRLPOOL 68b1e8fd892e1c54383de00becfb6e4807e222b6a0f6e11af3bce0b2d74c988647b0a093bc827ce4a9e63a93375040f0d7366df942cf8168e193ab436eb2fdb2
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.2.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.2.ebuild
new file mode 100644
index 000000000000..250f63303d4c
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ lwt? ( dev-ml/lwt:= )
+ ppx? ( dev-ml/ppx_tools:= )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable lwt)
+ $(use_enable async)
+ $(use_enable ppx)
+ --enable-unix
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )