summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-02-27 15:17:24 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-02-27 15:17:24 +0100
commit1cbd39c216c768505c36f8a25d11f67afb3cea38 (patch)
treea403117fd71d6e2b6e1d1bb6b9cf47fd50a85abd /dev-ml
parentapp-admin/mcelog: drop old (diff)
downloadgentoo-1cbd39c216c768505c36f8a25d11f67afb3cea38.tar.gz
gentoo-1cbd39c216c768505c36f8a25d11f67afb3cea38.tar.bz2
gentoo-1cbd39c216c768505c36f8a25d11f67afb3cea38.zip
dev-ml/ocamlgraph: remove gtk use flag
Bugs: https://bugs.gentoo.org/769320 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild b/dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..6001ee9fb27f
--- /dev/null
+++ b/dev-ml/ocamlgraph/ocamlgraph-2.0.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="O'Caml Graph library"
+HOMEPAGE="http://ocamlgraph.lri.fr/index.en.html"
+SRC_URI="https://github.com/backtracking/${PN}/releases/download/${PV}/${P}.tbz"
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+RDEPEND="
+ dev-ml/stdlib-shims:=[ocamlopt?]
+ dev-ml/graphics:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+IUSE="+ocamlopt"
+
+src_compile() {
+ dune build --only-packages ocamlgraph @install || die
+}