summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2020-02-10 01:49:58 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2020-02-10 01:53:37 +0100
commit265051f1c0d66801b385cfce96b75163a973b04a (patch)
treed7b932ed65e999a84a5318bf3bdb2609bba42af1 /dev-ml
parentnet-libs/zeromq: [QA] Fix dependency.equalsversion (diff)
downloadgentoo-265051f1c0d66801b385cfce96b75163a973b04a.tar.gz
gentoo-265051f1c0d66801b385cfce96b75163a973b04a.tar.bz2
gentoo-265051f1c0d66801b385cfce96b75163a973b04a.zip
dev-ml/camlp5: bump to 7.11
Bug: https://bugs.gentoo.org/708924 Package-Manager: Portage-2.3.88, Repoman-2.3.20 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/Manifest1
-rw-r--r--dev-ml/camlp5/camlp5-7.11.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ml/camlp5/Manifest b/dev-ml/camlp5/Manifest
index 8b95932ffc1b..e8a48e6da5cd 100644
--- a/dev-ml/camlp5/Manifest
+++ b/dev-ml/camlp5/Manifest
@@ -3,3 +3,4 @@ DIST camlp5-7.00.tar.gz 755750 BLAKE2B b047422ff34c4d15c21b65bd7473ccdad8bfc1f48
DIST camlp5-7.01.tar.gz 757118 BLAKE2B 5d7c6f39f24bfee545552aae5c126305d2c767d06762aa516c21bcc5b327b312b7c38d742717eb507b92ae1e27de9c0fcde4d616754a7ce616b5f56689c8dc5a SHA512 9930957f707d9d2c8903f87f5f3444f71bad3d84c944436c7abc6de19209595c974098cd60a6a391f8ae87c4fb53b5122cba8e42e34fcf46d798dbdc28840008
DIST camlp5-7.03.tar.gz 758136 BLAKE2B 4e1169adf7e119f1f659fe684a8b06c4730db3bcd7807169552de0e3fc115f8d45bc11961f3aee0a9c2d86e1130ec776a1bb7753d7d4e95f661d65d1f841406c SHA512 0c76d469c5f8c727088f3136107b6690349b50791ef8baefffdaa90141230907f977a7a886a9e8d88d39d8fa315637d882d0205c57d752e16575c888a8a1f54d
DIST camlp5-7.10.tar.gz 849559 BLAKE2B b05624156e914c2657d76afbf3dfacd295fe5985ae3809959a40029a8052669be6ae8a6ff889fbf2c602d3f19c9995f013b388c140738f4bb4f4da9970911ed5 SHA512 faa9e88f56477162038fc80429d5839c93b3e38aec90366730babe737e2e6bb260dc39975947a6601212cc0c68f465bdbccb6337da23c07181909dfb11cf8640
+DIST camlp5-7.11.tar.gz 878224 BLAKE2B f384764da43653a2f75664681a4f202ec84497720470a0a33f99fc61a1ce7b4a9d494ffe6b523c74906c122ee04ae25a08bf1fcd356145e85a11e3e3095bbf7d SHA512 109a43f0a3aaa7a3ba9bd51b1fc1273b054d32787e189b138d69b39c42642b480c13abb9e91f15e6b6e889eaf4dc422ad3ff51e4dee298fb9d8cd9a2db99c159
diff --git a/dev-ml/camlp5/camlp5-7.11.ebuild b/dev-ml/camlp5/camlp5-7.11.ebuild
new file mode 100644
index 000000000000..542b744b42f5
--- /dev/null
+++ b/dev-ml/camlp5/camlp5-7.11.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="A preprocessor-pretty-printer of ocaml"
+HOMEPAGE="https://camlp5.github.io/"
+SRC_URI="https://github.com/camlp5/camlp5/archive/rel$(ver_rs 1- '').tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-rel$(ver_rs 1- '')"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="doc +ocamlopt"
+
+DEPEND="dev-lang/ocaml"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGES DEVEL ICHANGES README.md UPGRADING MODE"
+
+src_configure() {
+ ./configure \
+ --strict \
+ -prefix /usr \
+ -bindir /usr/bin \
+ -libdir /usr/$(get_libdir)/ocaml \
+ -mandir /usr/share/man || die "configure failed"
+}
+
+src_compile(){
+ emake out
+ if use ocamlopt; then
+ emake opt
+ emake opt.opt
+ fi
+}
+
+src_install() {
+ use doc && HTML_DOCS="doc/*"
+
+ default
+
+ # findlib support
+ insinto "$(ocamlfind printconf destdir)/${PN}"
+ doins etc/META
+}