summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-22 10:36:33 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-22 11:06:59 +0100
commit2a26df1fecbf3ab00b676c94c5d45f64eb282df4 (patch)
treea588cb59954e1181e8a7e66513b726f58852f3ed /dev-ml
parentdev-ml/ppx_core: bump to 113.33.00 (diff)
downloadgentoo-2a26df1fecbf3ab00b676c94c5d45f64eb282df4.tar.gz
gentoo-2a26df1fecbf3ab00b676c94c5d45f64eb282df4.tar.bz2
gentoo-2a26df1fecbf3ab00b676c94c5d45f64eb282df4.zip
dev-ml/ppx_driver: bump to 113.33.00
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_driver/Manifest1
-rw-r--r--dev-ml/ppx_driver/ppx_driver-113.33.00.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/ppx_driver/Manifest b/dev-ml/ppx_driver/Manifest
index 3414b4b27b17..d7cab846aafe 100644
--- a/dev-ml/ppx_driver/Manifest
+++ b/dev-ml/ppx_driver/Manifest
@@ -1 +1,2 @@
DIST ppx_driver-113.24.00.tar.gz 58520 SHA256 d7f4a5eacdddf94f3babca15fe7a0212e8379639662af149a8f64a5ed6593f15 SHA512 c1c8c711e547f7c5bd87a36f004b5d06f88c3261728cb47195736ca09cab74b936ebd791252dae34c2995c48a605d0de77497b143a62a43a0e23f7bbbb53e000 WHIRLPOOL 12a6147defe38a90c767c9161b4d40f18392d626da101fa09bdc5e816fd5990388aab11106ae9c4d9ff188f11f314f8892fa9cd507fa5fec45fcfedcfd51e7ed
+DIST ppx_driver-113.33.00.tar.gz 59174 SHA256 e58e86e0e5cc4c038fd7ac4eeefdbb6b9a26036b9df24ea5e1cbe163edefe61e SHA512 b3644c138b5f2c23c6e9f2f6084121b91ef67d4131a29a17ff629d21e0d33e7c313f3d1531e1d87b4073bb6f10142e612d61e450a0690cf27443b573bbb28399 WHIRLPOOL 46223d2c5cb558c4a218939973c202c0f20ae0797202ccfc75f78eb63edb16f9411d533d1e63fce3b3e614e443f0df07fec317426290292171a7b0faa719866d
diff --git a/dev-ml/ppx_driver/ppx_driver-113.33.00.ebuild b/dev-ml/ppx_driver/ppx_driver-113.33.00.ebuild
new file mode 100644
index 000000000000..9e4a762fd5c0
--- /dev/null
+++ b/dev-ml/ppx_driver/ppx_driver-113.33.00.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Feature-full driver for OCaml AST transformers"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ >=dev-ml/ppx_core-113.33.00:=
+ dev-ml/ocamlbuild:=[ocamlopt?]
+ dev-ml/ppx_optcomp:="
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}