summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-22 14:36:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-22 16:24:34 +0200
commit2bbea554372d23a4db567b771b668981b3bbd596 (patch)
treef3cc0ceaecdc359f42aa1a8c258fb9da05a44590 /dev-ml
parentmedia-libs/zvbi: Fix building tests with gcc7. (diff)
downloadgentoo-2bbea554372d23a4db567b771b668981b3bbd596.tar.gz
gentoo-2bbea554372d23a4db567b771b668981b3bbd596.tar.bz2
gentoo-2bbea554372d23a4db567b771b668981b3bbd596.zip
dev-ml/patience_diff: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/patience_diff/Manifest1
-rw-r--r--dev-ml/patience_diff/metadata.xml11
-rw-r--r--dev-ml/patience_diff/patience_diff-0.9.0.ebuild30
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/patience_diff/Manifest b/dev-ml/patience_diff/Manifest
new file mode 100644
index 000000000000..fc6841360554
--- /dev/null
+++ b/dev-ml/patience_diff/Manifest
@@ -0,0 +1 @@
+DIST patience_diff-0.9.0.tar.gz 16520 SHA256 d47943ca89602e4c4b030f8dec7fa60b5011592a7005fa79cf746b79308d66f8 SHA512 62cc0950edd8d46d5a11cd612dbdb8dc531a9a2c71403f30e6022e20d9ee21cb2e7a531362fa8b350075003eec929f1f70481b8e160b253831966d80a8becd83 WHIRLPOOL f1bb11f6862c9612f48cb861b74028c7c4c720738f44ac75b42d47f527781f6d054d690ac3a36318a6ea3d754544f4e0b9e83627a781989f9c46f5fc4b524f01
diff --git a/dev-ml/patience_diff/metadata.xml b/dev-ml/patience_diff/metadata.xml
new file mode 100644
index 000000000000..949b707595ef
--- /dev/null
+++ b/dev-ml/patience_diff/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+ <upstream>
+ <remote-id type="github">janestreet/patience_diff</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/patience_diff/patience_diff-0.9.0.ebuild b/dev-ml/patience_diff/patience_diff-0.9.0.ebuild
new file mode 100644
index 000000000000..727b5d56ef37
--- /dev/null
+++ b/dev-ml/patience_diff/patience_diff-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Tool and library implementing patience diff"
+HOMEPAGE="https://github.com/janestreet/${PN}"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/core_kernel:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_jane:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+DEPEND="${RDEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}