summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-02-12 14:04:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-02-12 14:04:19 +0100
commit3c1d75c6f3abc653b58dedc65b27c8167b30d8d7 (patch)
tree2bab091964ae343e9485a93bf0b255130d81972f /dev-ml
parentapp-i18n/jfbterm: Modernise to EAPI 6 (diff)
downloadgentoo-3c1d75c6f3abc653b58dedc65b27c8167b30d8d7.tar.gz
gentoo-3c1d75c6f3abc653b58dedc65b27c8167b30d8d7.tar.bz2
gentoo-3c1d75c6f3abc653b58dedc65b27c8167b30d8d7.zip
dev-ml/ocaml-containers: Add 1.0 without keywords since it breaks its sole revdep.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-containers/Manifest1
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/Manifest b/dev-ml/ocaml-containers/Manifest
index 5fd1cfceeee2..a78513082b53 100644
--- a/dev-ml/ocaml-containers/Manifest
+++ b/dev-ml/ocaml-containers/Manifest
@@ -1 +1,2 @@
DIST ocaml-containers-0.22.1.tar.gz 429672 SHA256 2ef64e8ed93211dfd4f8cd594943db3cde81ee0400b17703d8a7993128634622 SHA512 9294d43485cd17998f9d0c758ee0ffdc187ea78f1f456c0b06a57a9401c6de529e9e68bad12908b2b0da5f22fca64835acb90f3dfd6ee3403bb7c3c301cd6821 WHIRLPOOL 67844578447b321439223b5f560258cb5d5417135dfdbfdaf2fa10e104beb764e9ca6ae0ab774864c974d928e75aa5aedc7e90ea5659d910f33349a7ec4b568b
+DIST ocaml-containers-1.0.tar.gz 378474 SHA256 d31239782eda4ffddc6358add3089e3a389aab7682b8202fd7db90075a703e75 SHA512 a22bd66c522f734c6081d1675af3d110cf1e9b4d3bd066aa9366c25fc840890a4ef779fa68ded84ef1b09df37fa7c217dfed1c15b1243f511ebfd24d7f0d2590 WHIRLPOOL a883d3052b400f66905441720164ee68e51353a4940ddcec0d05bef08533549dad7d428fce05d49a235a5a6586b3aca23ec757cf5abff6f4d84d5b75b8751569
diff --git a/dev-ml/ocaml-containers/ocaml-containers-1.0.ebuild b/dev-ml/ocaml-containers/ocaml-containers-1.0.ebuild
new file mode 100644
index 000000000000..e79487b775f2
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+# Breaks onanomsg, its sole revdep
+#KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/result:=
+ >=dev-ml/sequence-0.9:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo
+ test? ( dev-ml/iTeML )"
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}