summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-07 14:21:38 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-07 14:29:41 +0100
commit3d06c8336732004eb0c2c41cc7de64b04e0fca96 (patch)
treee0d2c985acac411e650cb840389e506ae35e5e9c /dev-ml
parentmedia-radio/unixcw: Version bump. Fix tinfo problem. (diff)
downloadgentoo-3d06c8336732004eb0c2c41cc7de64b04e0fca96.tar.gz
gentoo-3d06c8336732004eb0c2c41cc7de64b04e0fca96.tar.bz2
gentoo-3d06c8336732004eb0c2c41cc7de64b04e0fca96.zip
dev-ml/tyxml: Bump to 4.1.0
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/tyxml/Manifest1
-rw-r--r--dev-ml/tyxml/tyxml-4.1.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/tyxml/Manifest b/dev-ml/tyxml/Manifest
index 753893aa6733..bbf3405e2448 100644
--- a/dev-ml/tyxml/Manifest
+++ b/dev-ml/tyxml/Manifest
@@ -1 +1,2 @@
DIST tyxml-4.0.1.tar.gz 179609 SHA256 b7dbb6dbb8a02c0ab62f078695af6fbb636d162bd0f341fc9bda7d88ef9a1dfa SHA512 ebc0f148602375d8df16df7815f60ad6edcc7b4830af9479fb0e71a394d5d6dd7cb36e592d026b06677537d29be4359201e52f047ad3e23f34d82401b33b31e3 WHIRLPOOL 0b1f5c790f1d11fa503a23ff265b5e2cdb570fb61879d19c95f1d454f325066945607f5f54ffbf822500a58bd19a88906b92d7e9dc1a142bd051a5845ba1db91
+DIST tyxml-4.1.0.tar.gz 179852 SHA256 8721a46847735fbede8ce331f1b07d86699dd42f511deea668c1c886589bccd1 SHA512 add2b82939ea069ee74ee26ff3ee1f3ad2e361e593134da807e1acfbebff4ed546cbc23aca7ee2936a1eb8a736916d673aa2c96aeae8779706cd726bc2d07ead WHIRLPOOL 71b2eceea0820af9dd0b9d0b6581220f2b951d15f50e3face8a2d5c44bd53f3523fedfdf3d88affe4c6be23e6eaf23cacd39fe452c76b96cbbd3d02ce516c8ab
diff --git a/dev-ml/tyxml/tyxml-4.1.0.ebuild b/dev-ml/tyxml/tyxml-4.1.0.ebuild
new file mode 100644
index 000000000000..4ddf289c7b6e
--- /dev/null
+++ b/dev-ml/tyxml/tyxml-4.1.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+# Cannot find findlib package alcotest
+# OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A libary to build xml trees typechecked by OCaml"
+HOMEPAGE="http://ocsigen.org/tyxml/"
+SRC_URI="https://github.com/ocsigen/tyxml/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ppx +camlp4"
+
+DEPEND="
+ >=dev-ml/uutf-1.0:=
+ dev-ml/uchar:=
+ dev-ml/ocaml-re:=
+ ppx? ( >=dev-ml/ppx_tools-5:= dev-ml/markup:= )
+ camlp4? ( dev-ml/camlp4:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( CHANGES README.md )
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable camlp4 syntax)
+ $(use_enable ppx)
+ " oasis_src_configure
+}