summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-05-21 19:04:09 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-05-21 19:04:09 +0200
commit42825e870a32b5f52e4266f75bbc313129403c90 (patch)
tree53d1b667d3a03f18199f0393133e9eb69e36e67f /dev-ml
parentsci-libs/dealii: version bump to 9.2.0, update 9999 (diff)
downloadgentoo-42825e870a32b5f52e4266f75bbc313129403c90.tar.gz
gentoo-42825e870a32b5f52e4266f75bbc313129403c90.tar.bz2
gentoo-42825e870a32b5f52e4266f75bbc313129403c90.zip
dev-ml/num: use CFLAGS
Closes: https://bugs.gentoo.org/723748 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/num/files/num-1.3-cflags.patch11
-rw-r--r--dev-ml/num/num-1.3.ebuild8
2 files changed, 19 insertions, 0 deletions
diff --git a/dev-ml/num/files/num-1.3-cflags.patch b/dev-ml/num/files/num-1.3-cflags.patch
new file mode 100644
index 000000000000..771455c4f724
--- /dev/null
+++ b/dev-ml/num/files/num-1.3-cflags.patch
@@ -0,0 +1,11 @@
+--- a/src/Makefile 2020-05-21 18:54:31.176399032 +0200
++++ b/src/Makefile 2020-05-21 18:55:27.881498310 +0200
+@@ -65,7 +65,7 @@
+ %.cmx: %.ml
+ $(OCAMLOPT) $(CAMLOPTFLAGS) -c $*.ml
+ %.$(O): %.c
+- $(OCAMLC) -ccopt -DBNG_ARCH_$(BNG_ARCH) -c $*.c
++ $(OCAMLC) -ccopt "-DBNG_ARCH_$(BNG_ARCH) $(CFLAGS)" -c $*.c
+
+ # Legacy installation: files go into OCaml's stdlib directory; only META
+ # is installed via findlib
diff --git a/dev-ml/num/num-1.3.ebuild b/dev-ml/num/num-1.3.ebuild
index aaa82b73caa0..8cea14497085 100644
--- a/dev-ml/num/num-1.3.ebuild
+++ b/dev-ml/num/num-1.3.ebuild
@@ -19,6 +19,14 @@ DEPEND=">=dev-lang/ocaml-4.09.0[ocamlopt]
RDEPEND="${DEPEND}"
BDEPEND="${DEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+)
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
src_install() {
findlib_src_preinst
OCAMLPATH="${OCAMLFIND_DESTDIR}" emake install DESTDIR="${D}"