summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-17 09:57:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-17 09:57:07 +0200
commit42e8cf67e97f6530fb3c44b2d4859f024ec0a1c2 (patch)
treedc1d8dd1a5486ae1a8fbba6f5320ff490622e99b /dev-ml
parentdev-ml/atdgen: Bump to 1.10.2 (diff)
downloadgentoo-42e8cf67e97f6530fb3c44b2d4859f024ec0a1c2.tar.gz
gentoo-42e8cf67e97f6530fb3c44b2d4859f024ec0a1c2.tar.bz2
gentoo-42e8cf67e97f6530fb3c44b2d4859f024ec0a1c2.zip
dev-ml/ocaml-dns: Bump to 0.20.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-dns/Manifest1
-rw-r--r--dev-ml/ocaml-dns/ocaml-dns-0.20.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dns/Manifest b/dev-ml/ocaml-dns/Manifest
index bd87da976168..6d074d8b18cc 100644
--- a/dev-ml/ocaml-dns/Manifest
+++ b/dev-ml/ocaml-dns/Manifest
@@ -1 +1,2 @@
DIST ocaml-dns-0.20.0.tar.gz 98660 SHA256 27f83f6ef242df944b8b272eedbad736daa649f3b4efc77abf142ef3a7008e26 SHA512 fbf6bfd580e025454f08dfdfa38c2e2d4a1d6ba35941988ca22fad80c61a58f1124693daabb5b643b12c54aba5a445282ca79c460e9411341dbbccbf6cdb32dc WHIRLPOOL 56784fc226ced8a88807810602000d5956eba39276a2a69b05850ff97d6a624890ec8906b32eaacaaca6a80f784f04ff4947aa4a72a50f707a14e1f9500f4315
+DIST ocaml-dns-0.20.1.tar.gz 98673 SHA256 fb28e5e0e4d38ca52b13504f2e2c077f1257c589904f72c1d8bf52e5d7696599 SHA512 646d2620f718911021d3c42aa8bed0f78d20a565f6075cd6acba57ff41fd30e81446e4ebb80b25e9670124f9eda1314286207b1d3d92b335319d333c6728e7fb WHIRLPOOL b9d448bb14b7e284af319b2364b276c807b3bf8af96997b43337b4b0f450966ba95a1614baeec34fc2f91bc2d80e8ff0320af2947e45d9e0f3527f724aad8ce2
diff --git a/dev-ml/ocaml-dns/ocaml-dns-0.20.1.ebuild b/dev-ml/ocaml-dns/ocaml-dns-0.20.1.ebuild
new file mode 100644
index 000000000000..9e32c2f31ec4
--- /dev/null
+++ b/dev-ml/ocaml-dns/ocaml-dns-0.20.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="A pure OCaml implementation of the DNS protocol"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ocamlopt test"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ lwt? ( >=dev-ml/lwt-3:=
+ dev-ml/ocaml-cstruct:=[lwt(-)] )
+ >=dev-lang/ocaml-4:=
+ dev-ml/cmdliner:=
+ dev-ml/mirage-profile:=
+ >=dev-ml/ocaml-base64-2.0.0:=
+ >=dev-ml/ocaml-cstruct-1.9.0:=
+ >=dev-ml/ocaml-ipaddr-2.6.0:=
+ dev-ml/ocaml-re:=
+ >=dev-ml/ocaml-uri-1.7.0:=
+ dev-ml/ocaml-hashcons:=[ocamlopt?]
+ dev-lang/ocaml:=[ocamlopt?]
+ !<dev-ml/mirage-types-1.2.0
+ !dev-ml/odns
+"
+DEPEND="
+ test? (
+ dev-ml/ounit
+ dev-ml/ocaml-pcap
+ )
+ dev-ml/topkg
+ dev-ml/ppx_tools
+ ${RDEPEND}
+"
+# Missing mirage deps
+RESTRICT="test"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test true false) \
+ --with-lwt $(usex lwt true false) \
+ --with-async $(usex async true false) \
+ || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ dns.install || die
+ dodoc CHANGES.md README.md TODO.md
+}