summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-30 13:39:13 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-30 23:21:57 +0100
commit4cf640a8b699c46adb3900a858ae7fe517421a8f (patch)
treeb6000a591468aeeb7b4cd434337d4a32395fd0a6 /dev-ml
parentmedia-libs/gd: Security bump to version 2.2.4 (bug #607718). (diff)
downloadgentoo-4cf640a8b699c46adb3900a858ae7fe517421a8f.tar.gz
gentoo-4cf640a8b699c46adb3900a858ae7fe517421a8f.tar.bz2
gentoo-4cf640a8b699c46adb3900a858ae7fe517421a8f.zip
dev-ml/ocaml-ctypes: bump to 0.11.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 5d2d8d0d977e..2ef96db76ad8 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-ctypes-0.11.2.tar.gz 203564 SHA256 708e2c5501ba00b3ed6726a7da1c2b58f607859e8e1cc0381eefd222510488d6 SHA512 f3d75e9e596f68438733090fea8c675624c3b186a77c3adf1eca8f12cc2da336f0f5b1688c2ee788726e873bbb0c4dce1d237d53d1637d78e4ad6a8eae1f912a WHIRLPOOL cbf74628695e01dfe2e379a7c645313e36eaae98f733cda231a290960e52241c96bcc2fb8491daa28b964cf06c0d43a41282767a2d9fa1a4a6f395736eb08864
+DIST ocaml-ctypes-0.11.3.tar.gz 204959 SHA256 683b0215dca7bba797404869a80564cd4901a0a3f3c14bd65be7656c40b2329d SHA512 e7698954a6b683869a1482af8fe1bbeb5ccf693c2bb8583e2c19c5da92ed2730466e373c6f53d9ff9f09c2bdedf102da3f76b75511d7f9b7d266ac0765999f94 WHIRLPOOL ddeb6cf4b2b4c611bfe26f94974eaaa69415164825c5744d59b5afe388230cedad4d4c12b7d3753da31899af01f10c642f3478f9cc4270d49e70057023f61450
DIST ocaml-ctypes-0.4.1.tar.gz 162601 SHA256 74564e049de5d3c0e76ea284c225cb658ac1a2b483345be1efb9be4b3c1702f5 SHA512 8155ffe16a58d5714ceb602afa5531c93526defca39a16047328ac06d2c7c7f52b768b18170391f467e1f6919c69275734faf85d27315e11b8bbefcb1bc8afa9 WHIRLPOOL d8d0ef24e0b6c40f50fddf38fed7238cf95573909d2809cc2ab5c1b9b3dab333210e1ce99cf805804576a79d08d819e2ecdee7b4a6a9e13efb13e7b9f88ad802
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3.ebuild
new file mode 100644
index 000000000000..b94a5aa2bc8c
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}