summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-16 17:07:45 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-16 17:44:22 +0200
commit4dc4a4f1b79a47992c50d6f61c124618c4dbbf41 (patch)
tree43f18bc5172248d49aac3cb3050e2bd66c5be37c /dev-ml
parentdev-ml/csexp: bump to 1.5.2 (diff)
downloadgentoo-4dc4a4f1b79a47992c50d6f61c124618c4dbbf41.tar.gz
gentoo-4dc4a4f1b79a47992c50d6f61c124618c4dbbf41.tar.bz2
gentoo-4dc4a4f1b79a47992c50d6f61c124618c4dbbf41.zip
dev-ml/mtime: bump to 2.0.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/mtime/Manifest1
-rw-r--r--dev-ml/mtime/mtime-2.0.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/mtime/Manifest b/dev-ml/mtime/Manifest
index ea9c8b5f4578..b9d8614b95c4 100644
--- a/dev-ml/mtime/Manifest
+++ b/dev-ml/mtime/Manifest
@@ -1,2 +1,3 @@
DIST mtime-1.2.0.tbz 16272 BLAKE2B 317201f8d5e7a55636e58748ffd269db5e88aed012e8dd7ed269d1f128f8d21ed0e707679b030b9c822bac98c9b76033e8d2402171c4ee758d8c936fbeee7ee9 SHA512 0f0ed220cd0f899643930814010f8592e1f47b6dc6c4dce8eebfb17a81b0abed093a3dbf9c02490af99bf81ea640372f73b4ab88fd8ef0e0c7c66920692a8778
DIST mtime-1.4.0.tbz 15909 BLAKE2B 3c49deaf72d3873c8447f4a6d8ce89d55f3df60df108132ec078d81702a6fb9d532266efdf5290fe396d57a84de2d1912b48ad92f84db6d573d977492407b95b SHA512 0492fa5f5187b909fe2b0550363c7dcb8cffef963d51072272ef3d876b51e1ddf8de4c4e221cffb0144658fccf6a0dc584a5c8094a4b2208156e43bad5b269d4
+DIST mtime-2.0.0.tbz 16284 BLAKE2B de653a8ce5d53c53520f755f706d7eea8c13a53b0dcd27146d19b273b03bbc1582c77698f8e7b2148b4d1a3af63a37698978547945b06814fe9333c963619c08 SHA512 2ebec45218901c08f73420aa3318c506f155b6c0df713e9856682e59d3246696821ea477ce3682af0bf4cafd0491b1d66904f8c0256e2cf831e93a0aea322f04
diff --git a/dev-ml/mtime/mtime-2.0.0.ebuild b/dev-ml/mtime/mtime-2.0.0.ebuild
new file mode 100644
index 000000000000..89bcf7cd92cc
--- /dev/null
+++ b/dev-ml/mtime/mtime-2.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo opam
+
+DESCRIPTION="OCaml module to access monotonic wall-clock time"
+HOMEPAGE="https://erratique.ch/software/mtime/
+ https://github.com/dbuenzli/mtime/"
+SRC_URI="https://erratique.ch/software/mtime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="
+ ${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib
+"
+
+src_compile() {
+ edo ocaml pkg/pkg.ml build \
+ --tests $(usex test true false)
+}
+
+src_test() {
+ edo ocaml pkg/pkg.ml test
+}