summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-06 16:27:12 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-06 16:39:11 +0100
commit4ff20e362115e87f35719268388563706007e6e9 (patch)
treea3e5742bec5a7f3b49eaabaa3bf82f8f451dae0a /dev-ml
parentdev-ml/js_of_ocaml: Add X useflag (diff)
downloadgentoo-4ff20e362115e87f35719268388563706007e6e9.tar.gz
gentoo-4ff20e362115e87f35719268388563706007e6e9.tar.bz2
gentoo-4ff20e362115e87f35719268388563706007e6e9.zip
dev-ml/js_of_ocaml: add react useflag
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-2.7.ebuild6
-rw-r--r--dev-ml/js_of_ocaml/metadata.xml1
2 files changed, 4 insertions, 3 deletions
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-2.7.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-2.7.ebuild
index 3d6298a3f2ba..1bf41b5188af 100644
--- a/dev-ml/js_of_ocaml/js_of_ocaml-2.7.ebuild
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-2.7.ebuild
@@ -13,13 +13,12 @@ SRC_URI="https://github.com/ocsigen/js_of_ocaml/archive/${PV}.tar.gz -> ${P}.tar
LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
KEYWORDS="~amd64"
-IUSE="+ocamlopt doc +deriving X"
+IUSE="+ocamlopt doc +deriving +react X"
DEPEND="
>=dev-lang/ocaml-3.12:=[ocamlopt?,X?]
>=dev-ml/lwt-2.4.4:=
- dev-ml/react:=
- dev-ml/reactiveData:=
+ react? ( dev-ml/react:= dev-ml/reactiveData:= )
>=dev-ml/tyxml-3.6:=
dev-ml/cmdliner:=
dev-ml/menhir:=
@@ -35,6 +34,7 @@ src_configure() {
use ocamlopt || echo "NATDYNLINK := NO" >> Makefile.conf
use deriving || echo "WITH_DERIVING := NO" >> Makefile.conf
use X || echo "WITH_GRAPHICS := NO" >> Makefile.conf
+ use react || echo "WITH_REACT := NO" >> Makefile.conf
}
src_compile() {
diff --git a/dev-ml/js_of_ocaml/metadata.xml b/dev-ml/js_of_ocaml/metadata.xml
index 2a56cab9e11d..d3fd68ee65c8 100644
--- a/dev-ml/js_of_ocaml/metadata.xml
+++ b/dev-ml/js_of_ocaml/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="deriving">Enable <pkg>dev-ml/deriving</pkg> support for improving the type safety.</flag>
+ <flag name="react">Enable functionnal reactive programming support.</flag>
</use>
<upstream>
<remote-id type="github">ocsigen/js_of_ocaml</remote-id>