summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2020-12-17 09:47:16 -0500
committerAaron Bauman <bman@gentoo.org>2020-12-17 09:50:20 -0500
commit516e91635ee962fa5970ae635c28886305f951de (patch)
tree8b340549b242784b221303104901bbcf3b5bf42d /dev-ml
parentdev-vcs/cssc: drop old (diff)
downloadgentoo-516e91635ee962fa5970ae635c28886305f951de.tar.gz
gentoo-516e91635ee962fa5970ae635c28886305f951de.tar.bz2
gentoo-516e91635ee962fa5970ae635c28886305f951de.zip
dev-ml/findlib: drop old
Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/findlib-1.8.1.ebuild73
1 files changed, 0 insertions, 73 deletions
diff --git a/dev-ml/findlib/findlib-1.8.1.ebuild b/dev-ml/findlib/findlib-1.8.1.ebuild
deleted file mode 100644
index b2c69240deb4..000000000000
--- a/dev-ml/findlib/findlib-1.8.1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit multilib eutils
-
-DESCRIPTION="OCaml tool to find/use non-standard packages"
-HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
-SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
-IUSE="doc +ocamlopt tk"
-
-LICENSE="MIT"
-
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-
-DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]
- tk? ( dev-ml/labltk:= )"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- sed -i 's/\$llabltk \$lcamlp4 \$lobuild//' configure || die "Unable to make meta external."
- export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
- export stublibs="${ocamlfind_destdir}/stublibs"
-}
-
-src_configure() {
- local myconf
- use tk && myconf="-with-toolbox"
- ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
- -sitelib ${ocamlfind_destdir} \
- -config ${ocamlfind_destdir}/findlib/findlib.conf \
- -no-custom \
- ${myconf} || die "configure failed"
-}
-
-src_compile() {
- emake -j1 all
- if use ocamlopt; then
- emake -j1 opt # optimized code
- fi
-}
-
-src_install() {
- emake prefix="${D}" install
-
- dodir "${stublibs#${EPREFIX}}"
-
- cd "${S}/doc"
- dodoc QUICKSTART README DOCINFO
- use doc && dohtml -r ref-html guide-html
-}
-
-check_stublibs() {
- local ocaml_stdlib=`ocamlc -where`
- local ldconf="${ocaml_stdlib}/ld.conf"
-
- if [ ! -e ${ldconf} ]
- then
- echo "${ocaml_stdlib}" > ${ldconf}
- echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
- fi
-
- if [ -z `grep -e ${stublibs} ${ldconf}` ]
- then
- echo ${stublibs} >> ${ldconf}
- fi
-}
-
-pkg_postinst() {
- check_stublibs
-}