summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:50:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:59 +0200
commit586ea45db00b3a6b789d6f01dc9562f93dfda236 (patch)
tree8e0db00c3d22603173f8fc4c4078288da846d2ad /dev-ml
parentdev-ml/ppx_expect: Bump to 0.9.0 (diff)
downloadgentoo-586ea45db00b3a6b789d6f01dc9562f93dfda236.tar.gz
gentoo-586ea45db00b3a6b789d6f01dc9562f93dfda236.tar.bz2
gentoo-586ea45db00b3a6b789d6f01dc9562f93dfda236.zip
dev-ml/ppx_fail: bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ppx_fail/Manifest2
-rw-r--r--dev-ml/ppx_fail/files/oc43.patch35
-rw-r--r--dev-ml/ppx_fail/ppx_fail-0.9.0.ebuild32
-rw-r--r--dev-ml/ppx_fail/ppx_fail-113.33.00.ebuild45
4 files changed, 33 insertions, 81 deletions
diff --git a/dev-ml/ppx_fail/Manifest b/dev-ml/ppx_fail/Manifest
index 3455cc6ea4c8..5d2de757f921 100644
--- a/dev-ml/ppx_fail/Manifest
+++ b/dev-ml/ppx_fail/Manifest
@@ -1 +1 @@
-DIST ppx_fail-113.33.00.tar.gz 51294 SHA256 b5374ed6327298e26fe079b45f093f64d1975475b3c13f2c45f4c0ce0cc64390 SHA512 d52475bf9cf5edb50077bc4648f20d19c0d95c163d49244ac0786ab23a53de57b7d38a09429de6c91ab5f01251986e650f56647e7bb495da50f9999e838e69e7 WHIRLPOOL 395fb10fa80cb76733fd03059898dd2682384c732ee81fad1a905c6b3c2cfb0fa2326847ca0e035d65bb68c33710114f56edcad48d1e94efab3559e6a42d026b
+DIST ppx_fail-0.9.0.tar.gz 5908 SHA256 5623ba001719905dcad12c87614ebe35c61f3941f1553407928ef263fa6c30f3 SHA512 43bd13d5e41f7a297da2c67b032b9d88b94ab2ef152f756738e2bab41aa22829ec3a17d2824243e5194c4d2ee9ea567f06a638172f8c77ca7c466a641da8017a WHIRLPOOL ca9741d5a7f9fcd3c084de24e97b14ccb30a1233d1d93f614f6a4389d973022be35cde6966e9ec98477a56194055d7a2e9852018fdf66cf2352523d51a08d4db
diff --git a/dev-ml/ppx_fail/files/oc43.patch b/dev-ml/ppx_fail/files/oc43.patch
deleted file mode 100644
index c5dd6b23eb86..000000000000
--- a/dev-ml/ppx_fail/files/oc43.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -uNr ppx_fail-113.33.00/_oasis ppx_fail-113.33.00+4.03/_oasis
---- ppx_fail-113.33.00/_oasis 2016-03-09 16:44:54.000000000 +0100
-+++ ppx_fail-113.33.00+4.03/_oasis 2016-03-22 15:13:50.000000000 +0100
-@@ -1,8 +1,8 @@
- OASISFormat: 0.4
--OCamlVersion: >= 4.02.3
-+OCamlVersion: >= 4.03.0
- FindlibVersion: >= 1.3.2
- Name: ppx_fail
--Version: 113.33.00
-+Version: 113.33.00+4.03
- Synopsis: Add location to calls to failwiths
- Authors: Jane Street Group, LLC <opensource@janestreet.com>
- Copyrights: (C) 2015-2016 Jane Street Group LLC <opensource@janestreet.com>
-diff -uNr ppx_fail-113.33.00/opam ppx_fail-113.33.00+4.03/opam
---- ppx_fail-113.33.00/opam 2016-03-18 12:08:01.000000000 +0100
-+++ ppx_fail-113.33.00+4.03/opam 2016-03-22 17:51:36.000000000 +0100
-@@ -17,4 +17,4 @@
- "ppx_here"
- "ppx_tools" {>= "0.99.3"}
- ]
--available: [ ocaml-version >= "4.02.3" ]
-+available: [ ocaml-version >= "4.03.0" ]
-diff -uNr ppx_fail-113.33.00/src/ppx_fail.ml ppx_fail-113.33.00+4.03/src/ppx_fail.ml
---- ppx_fail-113.33.00/src/ppx_fail.ml 2016-03-09 16:44:54.000000000 +0100
-+++ ppx_fail-113.33.00+4.03/src/ppx_fail.ml 2016-03-22 15:13:50.000000000 +0100
-@@ -12,7 +12,7 @@
- match e.pexp_desc with
- | Pexp_ident { txt = Lident "failwiths"; _ } ->
- let loc = e.pexp_loc in
-- pexp_apply e ~loc [("here", Ppx_here_expander.lift_position ~loc)]
-+ pexp_apply e ~loc [(Labelled "here", Ppx_here_expander.lift_position ~loc)]
- | _ -> super#expression e
- end
-
diff --git a/dev-ml/ppx_fail/ppx_fail-0.9.0.ebuild b/dev-ml/ppx_fail/ppx_fail-0.9.0.ebuild
new file mode 100644
index 000000000000..8dce73e85a75
--- /dev/null
+++ b/dev-ml/ppx_fail/ppx_fail-0.9.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Add location to calls to failwiths"
+HOMEPAGE="https://github.com/janestreet/ppx_fail"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_here:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/ppx_fail/ppx_fail-113.33.00.ebuild b/dev-ml/ppx_fail/ppx_fail-113.33.00.ebuild
deleted file mode 100644
index 757016c57c32..000000000000
--- a/dev-ml/ppx_fail/ppx_fail-113.33.00.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit oasis
-
-DESCRIPTION="Add location to calls to failwiths"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-ml/ppx_tools:=
- dev-ml/ppx_core:=
- dev-ml/ppx_driver:=
- dev-ml/ppx_here:=
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/opam"
-
-src_prepare() {
- has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
-}
-
-src_configure() {
- emake setup.exe
- OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
- emake
-}
-
-src_install() {
- opam-installer -i \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- ${PN}.install || die
- dodoc CHANGES.md
-}