summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-12-12 21:26:56 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-12-13 09:15:54 +0100
commit5b2408a674c27546057849d9237469e8e24010a2 (patch)
treec627535c8e1f61f553526ac214904ef84320d203 /dev-ml
parentdev-ml/ocaml-cstruct: remove old (diff)
downloadgentoo-5b2408a674c27546057849d9237469e8e24010a2.tar.gz
gentoo-5b2408a674c27546057849d9237469e8e24010a2.tar.bz2
gentoo-5b2408a674c27546057849d9237469e8e24010a2.zip
dev-ml/ocaml-cstruct: bump to 2.3.1
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
index f0f4c80e251e..8b43aae5d5ac 100644
--- a/dev-ml/ocaml-cstruct/Manifest
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -1 +1,2 @@
DIST ocaml-cstruct-2.3.0.tar.gz 253518 SHA256 8b802e70c85879cd3b9bd4211d8c01e63f4dd4ac30288bd92d7a24d6c88b62eb SHA512 dc1927f20f35c823960be1e3cc6214304d72f2bda6a50b5fbc4f321eb0ab99bc8d1569421e74c249a915d2829f9c8dda171d7426c0b5526189db724ea5e59f72 WHIRLPOOL 3380c660012aae58996f574aff7d31eb461e92b78b4b4ab72111fc40d8bbbf258d6d776431304854542f00dc9127845dd297ec9fbca293dfaf04b334a0d68627
+DIST ocaml-cstruct-2.3.1.tar.gz 259266 SHA256 89a4f363547026de195fd84d9e842844ed6bbf4c5ab57c2fc1500741106b1797 SHA512 7dfb080f4d6f1685719ed31edd69cb5f4e484d42b28e0340dace8dd9a4742342957b67de0b10f0c4f4ccab7a80b13ddc3a26d2401cffdd232dc9581dba1da2ff WHIRLPOOL 6c41df0677217f45f13a03686e4a025da8f9edadccb5a27659cc1349bbae2f324a07d68e056f7078e4f4336d357c5558f262d0c6f4813017db0325e2b304b06e
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.1.ebuild
new file mode 100644
index 000000000000..ec1f10ab6940
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ lwt? ( dev-ml/lwt:= )
+ ppx? ( dev-ml/ppx_tools:= )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable lwt)
+ $(use_enable async)
+ $(use_enable ppx)
+ --enable-unix
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )