summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-22 13:39:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-24 13:07:15 +0200
commit5e4147fdf2f758359b33b66c9a985999945eca0a (patch)
tree310cca9ef47517a46002e9ef2afcc92246e36b1a /dev-ml
parentsci-electronics/kicad-4.0.5: Backport ebuild updates from 4.0.6, #617092 (diff)
downloadgentoo-5e4147fdf2f758359b33b66c9a985999945eca0a.tar.gz
gentoo-5e4147fdf2f758359b33b66c9a985999945eca0a.tar.bz2
gentoo-5e4147fdf2f758359b33b66c9a985999945eca0a.zip
dev-ml/findlib: bump to 1.7.2
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/findlib/Manifest1
-rw-r--r--dev-ml/findlib/files/externalmeta5.patch13
-rw-r--r--dev-ml/findlib/findlib-1.7.2.ebuild73
3 files changed, 87 insertions, 0 deletions
diff --git a/dev-ml/findlib/Manifest b/dev-ml/findlib/Manifest
index 7619bd49c240..2b1973372774 100644
--- a/dev-ml/findlib/Manifest
+++ b/dev-ml/findlib/Manifest
@@ -1 +1,2 @@
DIST findlib-1.7.1.tar.gz 256883 SHA256 5d4b9a79e9abf8be0b509f6b8cf5696221cbe14fa2fbb2bb352342755fd15eef SHA512 1c8002dc2ed1804afc78c2aa92ab55d2b6501fbb021a7ca46698b4de0dea8ad6485a64f7bf9ec5f3df888da1a420ab270efb5e26f1e408cc8b78fa3ccb981ba4 WHIRLPOOL e58d4939277a2b37fbf0ea4055281494d6b163ba806249d8019e4f3dc8c6ca079d9e904a5de6e86fe0d8bc59ed3894c962f86d6d87512f5b80757b8a59458dd1
+DIST findlib-1.7.2.tar.gz 257747 SHA256 48e571d35390082d8d8a0611ae3b4e00cfcc4bf7c487b9af99302ceec1b58980 SHA512 f2aadaf8630482785ebfe6788bfea6716defdd6ba94e7f4e3b743c3415fa5b169e31301d605857823e9c74f7bd2f774399ee32a8acb35e64ce0cba5e98e4dd2c WHIRLPOOL ef9a00f0335e01d8e96f1acea45a0e5c7f74381d878db3ebcefe0d81a1776ee661d9ab4105cf6543f5c7eb2d257fc6c11b33f14aea8fd88774157feba4439e3c
diff --git a/dev-ml/findlib/files/externalmeta5.patch b/dev-ml/findlib/files/externalmeta5.patch
new file mode 100644
index 000000000000..ac90722de3b3
--- /dev/null
+++ b/dev-ml/findlib/files/externalmeta5.patch
@@ -0,0 +1,13 @@
+Index: findlib-1.7.2/configure
+===================================================================
+--- findlib-1.7.2.orig/configure
++++ findlib-1.7.2/configure
+@@ -557,7 +557,7 @@ fi
+
+ # Generate the META files now.
+
+-l="$ldbm dynlink graphics $lnum num-top str threads unix stdlib bigarray ocamldoc $llabltk $lcamlp4 $lobuild $lcomplibs $lbytes $lspacetime"
++l="$ldbm dynlink graphics $lnum num-top str threads unix stdlib bigarray ocamldoc $lcomplibs $lbytes $lspacetime"
+
+ for dir in site-lib-src/*; do
+ # We do not really know if $dir is a directory.
diff --git a/dev-ml/findlib/findlib-1.7.2.ebuild b/dev-ml/findlib/findlib-1.7.2.ebuild
new file mode 100644
index 000000000000..3e2ddccc7ea3
--- /dev/null
+++ b/dev-ml/findlib/findlib-1.7.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit multilib eutils
+
+DESCRIPTION="OCaml tool to find/use non-standard packages"
+HOMEPAGE="http://projects.camlcity.org/projects/findlib.html"
+SRC_URI="http://download.camlcity.org/download/${P}.tar.gz"
+IUSE="doc +ocamlopt tk"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND=">=dev-lang/ocaml-4.02.3-r1:=[ocamlopt?]
+ tk? ( dev-ml/labltk:= )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/externalmeta5.patch"
+ export ocamlfind_destdir="${EPREFIX}/usr/$(get_libdir)/ocaml"
+ export stublibs="${ocamlfind_destdir}/stublibs"
+}
+
+src_configure() {
+ local myconf
+ use tk && myconf="-with-toolbox"
+ ./configure -bindir "${EPREFIX}"/usr/bin -mandir "${EPREFIX}"/usr/share/man \
+ -sitelib ${ocamlfind_destdir} \
+ -config ${ocamlfind_destdir}/findlib/findlib.conf \
+ -no-custom \
+ ${myconf} || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt # optimized code
+ fi
+}
+
+src_install() {
+ emake prefix="${D}" install
+
+ dodir "${stublibs#${EPREFIX}}"
+
+ cd "${S}/doc"
+ dodoc QUICKSTART README DOCINFO
+ use doc && dohtml -r ref-html guide-html
+}
+
+check_stublibs() {
+ local ocaml_stdlib=`ocamlc -where`
+ local ldconf="${ocaml_stdlib}/ld.conf"
+
+ if [ ! -e ${ldconf} ]
+ then
+ echo "${ocaml_stdlib}" > ${ldconf}
+ echo "${ocaml_stdlib}/stublibs" >> ${ldconf}
+ fi
+
+ if [ -z `grep -e ${stublibs} ${ldconf}` ]
+ then
+ echo ${stublibs} >> ${ldconf}
+ fi
+}
+
+pkg_postinst() {
+ check_stublibs
+}