summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-17 07:55:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-17 07:55:53 +0200
commit6764c607f357a453395e2782206b5e02eb8058e6 (patch)
tree71d275d9851640ed2934cf24b90109292939e0c3 /dev-ml
parentdev-ml/iTeML: bump to 2.7 (diff)
downloadgentoo-6764c607f357a453395e2782206b5e02eb8058e6.tar.gz
gentoo-6764c607f357a453395e2782206b5e02eb8058e6.tar.bz2
gentoo-6764c607f357a453395e2782206b5e02eb8058e6.zip
dev-ml/topkg: bump to 0.9.1
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/topkg/Manifest1
-rw-r--r--dev-ml/topkg/topkg-0.9.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/topkg/Manifest b/dev-ml/topkg/Manifest
index 8ea34acf7b37..a67afc7a8390 100644
--- a/dev-ml/topkg/Manifest
+++ b/dev-ml/topkg/Manifest
@@ -1 +1,2 @@
DIST topkg-0.9.0.tar.gz 120352 SHA256 1f9a718d49151ac4e914404e78865cc74e361d7befea2167fb8daa78a68fba11 SHA512 823fe1abb344d7800e09411c952bd276ecea97b5d9c124d986e26b9128d03b3ad023a38560198e476ef8f949ecb456078e332bda94075e9b746e43d3059a8fdb WHIRLPOOL 03be4f92aa654e46ffe46e49f59bac3fabb96982d512811fe1232fa067829ef09ba585bcf26bebba07aef1394497fd2551102dc97ba1f078b9b5e7d685c410be
+DIST topkg-0.9.1.tar.gz 120943 SHA256 7ad03b9ce97fbf39c040cdbd588d4cbcce97428e5dc84a23e27f2c43617f817f SHA512 19773eb764b53a6e5110c44d7942d2557d6c8502a3037b57f7737efc08f4cc374845b431fdb1465207693d15a4b072aea3db97f8e60e069e3d24ae150e8c5c8f WHIRLPOOL 93a2b08046672f88ea6a34e1f4d9c2af8432865c822bb751f029c6036c6e1975eeabc77c349a66559fa158f28f5807d799bb6e11b3168d1e0399924c3fadc754
diff --git a/dev-ml/topkg/topkg-0.9.1.ebuild b/dev-ml/topkg/topkg-0.9.1.ebuild
new file mode 100644
index 000000000000..2cfed454c256
--- /dev/null
+++ b/dev-ml/topkg/topkg-0.9.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib
+
+DESCRIPTION="The transitory OCaml software packager"
+HOMEPAGE="http://erratique.ch/software/topkg https://github.com/dbuenzli/topkg"
+SRC_URI="https://github.com/dbuenzli/topkg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-ml/result:=
+ dev-ml/ocamlbuild:=
+ dev-ml/findlib:=
+ dev-lang/ocaml:="
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --pkg-name ${PN} || die
+}
+
+src_install() {
+ # Can't use opam-installer here as it is an opam dep...
+ findlib_src_preinst
+ local nativelibs="$(echo _build/src/${PN}*.cm{x,xa,xs,ti} _build/src/${PN}.a)"
+ ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
+ dodoc CHANGES.md DEVEL.md README.md
+}