summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 11:33:54 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 11:34:12 +0100
commit749559f73ca3f3e45f8b1f57c46758518379db1c (patch)
treef8341101e13222e9b43a5a944865f53ffb0c44b8 /dev-ml
parentsys-devel/clang: Fix missing conditions around deps (diff)
downloadgentoo-749559f73ca3f3e45f8b1f57c46758518379db1c.tar.gz
gentoo-749559f73ca3f3e45f8b1f57c46758518379db1c.tar.bz2
gentoo-749559f73ca3f3e45f8b1f57c46758518379db1c.zip
dev-ml/llvm-ocaml: Fix missing conditions around deps
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild2
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
index dce57ce08f68..40fb0676b744 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
@@ -30,7 +30,7 @@ RDEPEND="
!sys-devel/llvm[ocaml(-)]"
for x in "${ALL_LLVM_TARGETS[@]}"; do
RDEPEND+="
- ~sys-devel/llvm-${PV}[${x}]"
+ ${x}? ( ~sys-devel/llvm-${PV}[${x}] )"
done
unset x
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
index 53bd69a34cec..7f6ae880e2cb 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-12.0.0.9999.ebuild
@@ -30,7 +30,7 @@ RDEPEND="
!sys-devel/llvm[ocaml(-)]"
for x in "${ALL_LLVM_TARGETS[@]}"; do
RDEPEND+="
- ~sys-devel/llvm-${PV}[${x}]"
+ ${x}? ( ~sys-devel/llvm-${PV}[${x}] )"
done
unset x