summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-20 23:08:32 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-23 20:30:43 +0200
commit7a8588f407a586b1d13eca1ffa0eec3b7d0f0139 (patch)
tree9f5cbe55b292440a5e530573d1003b436cc96242 /dev-ml
parentdev-python/lit: Dedupe with new eclass code (diff)
downloadgentoo-7a8588f407a586b1d13eca1ffa0eec3b7d0f0139.tar.gz
gentoo-7a8588f407a586b1d13eca1ffa0eec3b7d0f0139.tar.bz2
gentoo-7a8588f407a586b1d13eca1ffa0eec3b7d0f0139.zip
dev-ml/llvm-ocaml: Dedupe with new eclass code
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.9999.ebuild17
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild17
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild17
3 files changed, 6 insertions, 45 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.9999.ebuild
index c87d9f13cf31..c7b4967353fd 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
+inherit cmake-utils llvm llvm.org python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
@@ -38,24 +38,11 @@ BDEPEND="
test? ( dev-ml/ounit )
${PYTHON_DEPS}"
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
pkg_setup() {
LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
python-any-r1_pkg_setup
}
-src_prepare() {
- # Python is needed to run tests using lit
- python_setup
-
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake-utils_src_prepare
-}
-
src_configure() {
local libdir=$(get_libdir)
local mycmakeargs=(
@@ -89,7 +76,7 @@ src_configure() {
)
use test && mycmakeargs+=(
- -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags)"
)
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild
index ff77167a7661..7cff2bc42841 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.1_rc1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
-inherit cmake llvm llvm.org multiprocessing python-any-r1
+inherit cmake llvm llvm.org python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
@@ -38,24 +38,11 @@ BDEPEND="
test? ( dev-ml/ounit )
${PYTHON_DEPS}"
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
pkg_setup() {
LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
python-any-r1_pkg_setup
}
-src_prepare() {
- # Python is needed to run tests using lit
- python_setup
-
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake_src_prepare
-}
-
src_configure() {
local libdir=$(get_libdir)
local mycmakeargs=(
@@ -89,7 +76,7 @@ src_configure() {
)
use test && mycmakeargs+=(
- -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags)"
)
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
index 5a10d4d1de5c..f10bf23e527d 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils llvm llvm.org multiprocessing python-any-r1
+inherit cmake-utils llvm llvm.org python-any-r1
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
@@ -38,24 +38,11 @@ BDEPEND="
test? ( dev-ml/ounit )
${PYTHON_DEPS}"
-# least intrusive of all
-CMAKE_BUILD_TYPE=RelWithDebInfo
-
pkg_setup() {
LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
python-any-r1_pkg_setup
}
-src_prepare() {
- # Python is needed to run tests using lit
- python_setup
-
- # cmake eclasses suck by forcing ${S} here
- CMAKE_USE_DIR=${S} \
- S=${WORKDIR} \
- cmake-utils_src_prepare
-}
-
src_configure() {
local libdir=$(get_libdir)
local mycmakeargs=(
@@ -89,7 +76,7 @@ src_configure() {
)
use test && mycmakeargs+=(
- -DLLVM_LIT_ARGS="-vv;-j;${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}"
+ -DLLVM_LIT_ARGS="$(get_lit_flags)"
)
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844