summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-09-21 10:32:43 +0200
committerMichał Górny <mgorny@gentoo.org>2019-09-21 11:15:26 +0200
commit7f6b5a234aa3c3d80fcc029f76918851094b3355 (patch)
treecf7e4d483a8ddb090685a0a45a90e64ce4fe5369 /dev-ml
parentsys-devel/llvmgold: Bump -9 to EAPI 7 (diff)
downloadgentoo-7f6b5a234aa3c3d80fcc029f76918851094b3355.tar.gz
gentoo-7f6b5a234aa3c3d80fcc029f76918851094b3355.tar.bz2
gentoo-7f6b5a234aa3c3d80fcc029f76918851094b3355.zip
dev-ml/llvm-ocaml: Reorder ebuild vars in 9+
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild3
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild3
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild6
3 files changed, 4 insertions, 8 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
index 3fd5dbb40b8e..5fb5269eb058 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-10.0.0.9999.ebuild
@@ -28,6 +28,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="debug test ${ALL_LLVM_TARGETS[*]}"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -44,8 +45,6 @@ BDEPEND="
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
-
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild
index fad71890f1af..ea47038cb443 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.9999.ebuild
@@ -27,6 +27,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0/${PV}"
KEYWORDS=""
IUSE="debug test ${ALL_LLVM_TARGETS[*]}"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -43,8 +44,6 @@ BDEPEND="
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
-
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild
index 9c9c5f6b2440..44c293f604cc 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-9.0.0.ebuild
@@ -14,6 +14,7 @@ MY_P=llvm-${PV/_/}.src
DESCRIPTION="OCaml bindings for LLVM"
HOMEPAGE="https://llvm.org/"
SRC_URI="https://releases.llvm.org/${PV}/${MY_P}.tar.xz"
+S=${WORKDIR}/${MY_P}
# Keep in sync with sys-devel/llvm
ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM BPF Hexagon Lanai Mips MSP430
@@ -25,6 +26,7 @@ LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="debug test ${ALL_LLVM_TARGETS[*]}"
+REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
RESTRICT="!test? ( test )"
RDEPEND="
@@ -41,10 +43,6 @@ BDEPEND="
!!<dev-python/configparser-3.3.0.2
${PYTHON_DEPS}"
-REQUIRED_USE="|| ( ${ALL_LLVM_TARGETS[*]} )"
-
-S=${WORKDIR}/${MY_P}
-
# least intrusive of all
CMAKE_BUILD_TYPE=RelWithDebInfo