summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-10 14:44:14 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-11 10:14:07 +0100
commit8b6d66f7ff988333f56d5e45b1e0293adebe64bb (patch)
tree3a403b44b318becf1556f710a6bb60268a468cd4 /dev-ml
parentx11-misc/xowl: Fix description. (diff)
downloadgentoo-8b6d66f7ff988333f56d5e45b1e0293adebe64bb.tar.gz
gentoo-8b6d66f7ff988333f56d5e45b1e0293adebe64bb.tar.bz2
gentoo-8b6d66f7ff988333f56d5e45b1e0293adebe64bb.zip
dev-ml/opam: Bump to 1.3.1
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/opam/Manifest1
-rw-r--r--dev-ml/opam/opam-1.3.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/opam/Manifest b/dev-ml/opam/Manifest
index 9e786d9250d8..cdd3845a4be7 100644
--- a/dev-ml/opam/Manifest
+++ b/dev-ml/opam/Manifest
@@ -1 +1,2 @@
DIST opam-1.3.0.tar.gz 669389 SHA256 9d50122940f44401c2dcee39b12a4e4afea851b2f2ab47d90b522f7395f10f7a SHA512 290535a1bb2e7eff6ab44126c5070d2bed94e68cee3bd5e47054f91ad81ed92e9a21f7888bd1dafcb397e3ac61589d4eaf7267305ac63d1aee08761701bdf647 WHIRLPOOL 64b8fc334b8dd193af1d4ae0d0bb445554f6afeb3007fefd4048816d1bd90363c7b18c4d44521da8162bc3ae49668d26b75ef811a4de4d5287597024d0b74ddd
+DIST opam-1.3.1.tar.gz 669485 SHA256 625767c3465219cc8799aad1449c74279b31686db0821300cfdb92fbff17e9fd SHA512 d075c9b2c9670d712f29bd2df34b8020da52041fa2bbef599cb54a81f63554507d78bebece45ecf668d3d1d4ed514e4ab88a1d86b64088d283bca7a8e75ae582 WHIRLPOOL 8fcddf18056503b2010e8377175c5af87b098cec977fbedabcafc4178817b780bd538ae672600f5a7bdca423c99aefab24a7341f17e40465a9f3e1f1c3324623
diff --git a/dev-ml/opam/opam-1.3.1.ebuild b/dev-ml/opam/opam-1.3.1.ebuild
new file mode 100644
index 000000000000..10441e2b2ac6
--- /dev/null
+++ b/dev-ml/opam/opam-1.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A source-based package manager for OCaml"
+HOMEPAGE="http://opam.ocaml.org/"
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+if [[ ${PV} != 9999 ]]; then
+ SRC_URI="https://github.com/ocaml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ocaml/opam.git"
+fi
+
+DEPEND="dev-lang/ocaml:=
+ || ( net-misc/wget net-misc/curl )
+ dev-ml/extlib:=
+ dev-ml/ocaml-re:=
+ dev-ml/ocamlgraph:=
+ dev-ml/cmdliner:=
+ dev-ml/cudf:=
+ >=dev-ml/dose3-5:=
+ dev-ml/uutf:=
+ dev-ml/jsonm:=
+"
+RDEPEND="${DEPEND}
+ dev-ml/findlib
+"
+
+src_compile() {
+ emake -j1
+ cd doc
+ emake man
+}
+
+src_test() {
+ EMAIL=foo@bar.com emake -j1 tests
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" OPAMINSTALLER_FLAGS="--prefix=\"${ED}/usr\" --libdir=\"${D}/$(ocamlc -where)\"" libinstall
+}