summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-25 15:06:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-25 15:12:22 +0200
commit9458906d4ee435f61a647a976deb16ebc4f01145 (patch)
treef9c49d301b79e306d19d504d33f032f9cc4a49d4 /dev-ml
parentdev-ml/dns-async: import split package from ocaml-dns (diff)
downloadgentoo-9458906d4ee435f61a647a976deb16ebc4f01145.tar.gz
gentoo-9458906d4ee435f61a647a976deb16ebc4f01145.tar.bz2
gentoo-9458906d4ee435f61a647a976deb16ebc4f01145.zip
dev-ml/dns-lwt: import split package from ocaml-dns
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/dns-lwt/Manifest1
-rw-r--r--dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild52
-rw-r--r--dev-ml/dns-lwt/metadata.xml11
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-ml/dns-lwt/Manifest b/dev-ml/dns-lwt/Manifest
new file mode 100644
index 000000000000..467ed0a3eec9
--- /dev/null
+++ b/dev-ml/dns-lwt/Manifest
@@ -0,0 +1 @@
+DIST ocaml-dns-1.0.0.tar.gz 99161 SHA256 823410badaf2faf54ca8a59472b0ad82c4db9fe4ef92f6809061baa826851226 SHA512 199653605e985851dcaafc94f1efeba5c261c29cd5e5f8eaebc9f7d25a05c43adcf7620efb291b22f9549f7c05f8ac3f6abfbcf40e0d7762bd2f7cd623ebcb1c WHIRLPOOL e7c26857270d92be2e8e068ac29119ef5d82d52fd739b8304e84c595d6a6e7fc11c22ed98e4a6d99a20f4e9d1d6b28dbc76c333d6b464bbd1dc4d37597cfe66c
diff --git a/dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild b/dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild
new file mode 100644
index 000000000000..dd4d0e5c9428
--- /dev/null
+++ b/dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+MY_P=ocaml-dns-${PV}
+
+DESCRIPTION="Lwt support of OCaml DNS"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/ocaml-dns/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4:=
+ dev-ml/lwt:=
+ dev-ml/ocaml-dns:=
+ dev-ml/mirage-profile:=
+"
+DEPEND="
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? (
+ dev-ml/dns-lwt-unix
+ )
+ ${RDEPEND}
+"
+# do not work
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ jbuilder build @install -p ${PN} || die
+}
+
+src_test() {
+ jbuilder runtest -p ${PN} || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}
diff --git a/dev-ml/dns-lwt/metadata.xml b/dev-ml/dns-lwt/metadata.xml
new file mode 100644
index 000000000000..2f4ef14adaa5
--- /dev/null
+++ b/dev-ml/dns-lwt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mirage/ocaml-dns</remote-id>
+ </upstream>
+</pkgmetadata>