summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-08 18:25:41 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-08 18:49:50 +0200
commitaa40c7fc15262b01dd3bf72b81d27830aef304d2 (patch)
treee18bb74218455a699f8333323fac8b14c428295d /dev-ml
parentdev-ml/ppx_tools_versioned: bump to 5.0.1 (diff)
downloadgentoo-aa40c7fc15262b01dd3bf72b81d27830aef304d2.tar.gz
gentoo-aa40c7fc15262b01dd3bf72b81d27830aef304d2.tar.bz2
gentoo-aa40c7fc15262b01dd3bf72b81d27830aef304d2.zip
dev-ml/ocaml-cstruct: bump to 3.0.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ocaml-cstruct/Manifest1
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/Manifest b/dev-ml/ocaml-cstruct/Manifest
index 3bd8844ee874..7ba539a07442 100644
--- a/dev-ml/ocaml-cstruct/Manifest
+++ b/dev-ml/ocaml-cstruct/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-cstruct-2.4.0.tar.gz 259372 SHA256 a3e19e6a57204a5172c9ed0abd5153d85925b2d32f5ae51a53868a287be647fb SHA512 c37d16605f929aeeda33166183dcbe6b8e367583a8b25fde1bb5a4f9141a11f93e6f5463a500907d8829cb285075a8d2ca7874618a92f817997f76258175cbb3 WHIRLPOOL 8812fff7e3cc2a715e8ba395ab852752c0cf28bf8828e61de3f01b52ffabbc61c13c05b03fc964d1f68e88f33ce08c18b44a070881d3b876283fb987b945c664
DIST ocaml-cstruct-2.4.1.tar.gz 259399 SHA256 f3c1600e85eb93a58c052e2e9575b48d4dd02784d9b2615dadf861860afa1ee7 SHA512 30c541e50dc221d3d8df54f9a8dfa1f88b10f49b276779f7355a38effdfe048de0300bfcc7e361715f63b696d42bd11aa120df6b4058d3b24962777e91b1633e WHIRLPOOL 40d1fcf4674ee47595f14583f964850b4e2b8747f788efb947994ae5b59e12115c381afa7ccc269b408df2b0eed1e02967e83a6fa256aca8926401e6b3e0ed75
+DIST ocaml-cstruct-3.0.0.tar.gz 205057 SHA256 65c1b34a71029e52f440831daa8ab97bc4c1502714cf553fbd114726a18b8631 SHA512 7cb55ac6e876a6401463bbad452a1e58e959044b77b5e684bb340559817ebe1d5e632a7e95e16304e85b1db4032279a65e5d8da43a9d165a2e93ecaf2a6301d7 WHIRLPOOL 50756f9c777e7c62e2b8af450a1023a7fc0c5398d351eafe0e26a75a6159038190c2a6161b9fff7fcb4d82a17ab9ec9728ab4686ad146ee583693361208693f3
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.0.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.0.ebuild
new file mode 100644
index 000000000000..706a1c75b2b6
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-3.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx test"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ lwt? ( dev-ml/lwt:= )
+ ppx? (
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_tools_versioned:=
+ )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+oinstall() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${1}.install || die
+}
+
+src_install() {
+ oinstall cstruct
+ oinstall cstruct-unix
+ use lwt && oinstall cstruct-lwt
+ use async && oinstall cstruct-async
+ use ppx && oinstall ppx_cstruct
+}