summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-15 09:17:20 +0100
committerSam James <sam@gentoo.org>2021-04-16 12:16:26 +0100
commitc25f1be7c9bc0583dc21de55f30279d6976ac55d (patch)
treecae4dfddefed1a2fed02964539410d7f621a85c0 /dev-ml
parentdev-ml/opam: eutils->epatch (diff)
downloadgentoo-c25f1be7c9bc0583dc21de55f30279d6976ac55d.tar.gz
gentoo-c25f1be7c9bc0583dc21de55f30279d6976ac55d.tar.bz2
gentoo-c25f1be7c9bc0583dc21de55f30279d6976ac55d.zip
dev-ml/xml-light: eutils->epatch
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/xml-light/xml-light-2.2-r3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-ml/xml-light/xml-light-2.2-r3.ebuild b/dev-ml/xml-light/xml-light-2.2-r3.ebuild
index acc3930daa92..432a85bf453e 100644
--- a/dev-ml/xml-light/xml-light-2.2-r3.ebuild
+++ b/dev-ml/xml-light/xml-light-2.2-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=5
-inherit eutils multilib
+inherit epatch multilib
DESCRIPTION="Minimal Xml parser and printer for OCaml"
HOMEPAGE="http://tech.motion-twin.com/xmllight.html"
@@ -27,9 +27,11 @@ src_prepare() {
src_compile() {
emake -j1
+
if use ocamlopt; then
emake -j1 opt
fi
+
if use doc;then
emake doc
fi
@@ -52,9 +54,11 @@ archive(byte)="xml-light.cma"
EOF
if use ocamlopt; then
emake INSTALLDIR="${D}"/usr/$(get_libdir)/ocaml/${PN} installopt
- echo 'archive(native)="xml-light.cmxa"' >> "${D}"/usr/$(get_libdir)/ocaml/${PN}/META
+ echo 'archive(native)="xml-light.cmxa"' >> "${ED}"/usr/$(get_libdir)/ocaml/${PN}/META || die
fi
+
dodoc README
+
if use doc; then
emake doc
dohtml doc/*