summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-14 18:40:37 +0000
committerSam James <sam@gentoo.org>2021-06-14 18:40:55 +0000
commitc2c0cc0e8cfc9c592252a0c6d5e5ff23a6215c4e (patch)
tree2fa00b466fab3c8d7a6a550bf816ae8e64db2e3c /dev-ml
parentmedia-gfx/cura: drop old (diff)
downloadgentoo-c2c0cc0e8cfc9c592252a0c6d5e5ff23a6215c4e.tar.gz
gentoo-c2c0cc0e8cfc9c592252a0c6d5e5ff23a6215c4e.tar.bz2
gentoo-c2c0cc0e8cfc9c592252a0c6d5e5ff23a6215c4e.zip
dev-ml/topkg: fix build without ocamlopt
Closes: https://bugs.gentoo.org/795987 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/topkg/topkg-1.0.3.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/dev-ml/topkg/topkg-1.0.3.ebuild b/dev-ml/topkg/topkg-1.0.3.ebuild
index 15977974d687..6afcb25f56be 100644
--- a/dev-ml/topkg/topkg-1.0.3.ebuild
+++ b/dev-ml/topkg/topkg-1.0.3.ebuild
@@ -12,12 +12,12 @@ SRC_URI="https://github.com/dbuenzli/topkg/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="ISC"
SLOT="0/${PV}"
KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE=""
+IUSE="+ocamlopt"
RDEPEND="dev-ml/result:=
dev-ml/ocamlbuild:=
dev-ml/findlib:=
- dev-lang/ocaml:="
+ dev-lang/ocaml:=[ocamlopt?]"
DEPEND="${RDEPEND}"
src_compile() {
@@ -27,7 +27,12 @@ src_compile() {
src_install() {
# Can't use opam-installer here as it is an opam dep...
findlib_src_preinst
- local nativelibs="$(echo _build/src/${PN}*.cm{x,xa,xs,ti} _build/src/${PN}.a)"
+
+ local nativelibs
+ if use ocamlopt; then
+ nativelibs=$(echo _build/src/${PN}*.cm{x,xa,xs,ti} _build/src/${PN}.a)
+ fi
+
ocamlfind install ${PN} _build/pkg/META _build/src/${PN}.mli _build/src/${PN}.cm{a,i} ${nativelibs} || die
dodoc CHANGES.md DEVEL.md README.md
}