summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-03 12:08:05 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-03 12:28:42 +0100
commitc4944c3f1574fab9ad8ba99fe8b742cdc225f961 (patch)
tree53a5f65464a326c021d1cfc34fa7740d9ff4527f /dev-ml
parentapp-arch/lrzip: version bump to 0.631 (diff)
downloadgentoo-c4944c3f1574fab9ad8ba99fe8b742cdc225f961.tar.gz
gentoo-c4944c3f1574fab9ad8ba99fe8b742cdc225f961.tar.bz2
gentoo-c4944c3f1574fab9ad8ba99fe8b742cdc225f961.zip
dev-ml/pxp: Bump to 1.2.9
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/pxp/Manifest1
-rw-r--r--dev-ml/pxp/pxp-1.2.9.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-ml/pxp/Manifest b/dev-ml/pxp/Manifest
index 578c26c86d41..ab3b65350d7b 100644
--- a/dev-ml/pxp/Manifest
+++ b/dev-ml/pxp/Manifest
@@ -1 +1,2 @@
DIST pxp-1.2.8.tar.gz 619689 SHA256 701754f4460595434ea6db77c33e046d33e4a485e8d28c5d39ced56112c94452 SHA512 3292bfbda494066e454331a9cfc56b03f55afe8548bdf24fea09d9bc0a03c333c027f7b527983bd9b4d659458c95acf7e3fc251c72d26ab3502f52067c9f2549 WHIRLPOOL 5529a6ad818428b03664764704e62d200802dc26c8c344897f4b15b17945e4620fa4b878f0108b12f346000a7cc070b50d2ce82d945c6bcd34a0e5e811ec8c0a
+DIST pxp-1.2.9.tar.gz 626001 SHA256 b1ba8f305913b7e9d0bcbce0c532aeb28a79396e08f178b119c2050835ab1c7b SHA512 d3a8ab9eab0f5219b889dc7a0b4936e4ae81f2dd3eb06c45b25ff70b8e2c6151c917bf43cf84a90061c6efe0ec344c2703566d2d513e45e1fceab5740bdf9808 WHIRLPOOL 80ec9c681464821931d2b0ec6e7034023b1300bf56b42bfc33720c309e3290697cd20efe98c869949a80710f01460bf6896ba6f7a8413c3beef884eef9b74c85
diff --git a/dev-ml/pxp/pxp-1.2.9.ebuild b/dev-ml/pxp/pxp-1.2.9.ebuild
new file mode 100644
index 000000000000..58fa81ed2194
--- /dev/null
+++ b/dev-ml/pxp/pxp-1.2.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit findlib eutils
+
+MY_P=${P/_beta/test}
+
+DESCRIPTION="validating XML parser library for O'Caml"
+HOMEPAGE="http://projects.camlcity.org/projects/pxp.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+SLOT="0/${PV}"
+DEPEND=">=dev-ml/pcre-ocaml-4.31:=
+ >=dev-ml/ulex-0.5:=
+ >=dev-ml/ocamlnet-4:=
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ dev-ml/camlp4:="
+RDEPEND="${DEPEND}"
+
+IUSE="examples +ocamlopt"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ #the included configure does not support many standard switches and is quite picky
+ ./configure || die "configure failed"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ findlib_src_install
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ cd doc
+ dodoc ABOUT-FINDLIB README SPEC design.txt
+}