summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-16 15:35:22 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-16 15:35:22 +0200
commitc9b03416ca8444e60e020aadc2050d53cb9cf033 (patch)
tree7561f987ba4834e0a21aeec36cd23a4ddebff2b9 /dev-ml
parentdev-ml/batteries: bump to 2.5.2 (diff)
downloadgentoo-c9b03416ca8444e60e020aadc2050d53cb9cf033.tar.gz
gentoo-c9b03416ca8444e60e020aadc2050d53cb9cf033.tar.bz2
gentoo-c9b03416ca8444e60e020aadc2050d53cb9cf033.zip
dev-ml/parmap: add a version that works with ocaml 4.03
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/parmap/Manifest1
-rw-r--r--dev-ml/parmap/parmap-1.0_rc7-r1.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/parmap/Manifest b/dev-ml/parmap/Manifest
index 30a9989c0092..3cc71eecfb2c 100644
--- a/dev-ml/parmap/Manifest
+++ b/dev-ml/parmap/Manifest
@@ -1 +1,2 @@
+DIST parmap-1.0_rc7-ocaml-4.03.tar.gz 98262 SHA256 78f3baa7f9b9c7b5e2a3571624b844fce2b0b9f8744ebf5309ad880e74940fbb SHA512 c8b7678fede76d35b299ef0548ef3819f9ec056cde4d5498e11f2400b96149b17ce58c35d197d10dba5fd4a702b94fe78090e1f330791b0f470891f0bbf7a544 WHIRLPOOL 1e21a0676458222938afab3feec4f23048537870b10fa62a4c213368642eed642d3c4cf0e167d3267a7d0237be7ea0e1c13e8c164a8020a5f32acb7b1f4e568b
DIST parmap-1.0_rc7.tar.gz 97799 SHA256 b993d47b8b8e5342839b851b46aba52264b4f8c527db08f3124ed7a7de7e1912 SHA512 50ac96f0f8b835298958f1a8ca65a2e488eab9c86f5fd57b43d5cd8145c71594a537add568dbe8f471d41157701769e35d0e992b07b430252623b72d7488d562 WHIRLPOOL 54842d45a7495316f42ae63de08db88512adddc1ee743a70de5a899d4c35e7a2e062bfc6f9456c65a32d2279784eb291f0299fd9b785e59e3607dec193f7f01d
diff --git a/dev-ml/parmap/parmap-1.0_rc7-r1.ebuild b/dev-ml/parmap/parmap-1.0_rc7-r1.ebuild
new file mode 100644
index 000000000000..7cb94dce838d
--- /dev/null
+++ b/dev-ml/parmap/parmap-1.0_rc7-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+MY_PV="${PV/_/-}-fix-for4.03+3"
+DESCRIPTION="Library allowing to exploit multicore architectures for OCaml programs with minimal modifications"
+HOMEPAGE="http://www.dicosmo.org/code/parmap/"
+SRC_URI="https://github.com/rdicosmo/parmap/archive/${MY_PV}.tar.gz -> ${P}-ocaml-4.03.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ dev-ml/ocaml-autoconf"
+S="${WORKDIR}/${PN}-${MY_PV/+/-}"
+
+src_test() {
+ mkdir "${WORKDIR}/tmpinstall" || die
+ emake \
+ OCAMLLIBDIR="ocaml" \
+ DESTDIR="${WORKDIR}/tmpinstall" \
+ install
+ export OCAMLPATH="${WORKDIR}/tmpinstall/ocaml"
+ emake tests
+ cd _build/tests || die
+ for i in $(find . -type f -executable) ; do
+ ${i} || die
+ done
+}
+
+src_install() {
+ emake \
+ OCAMLLIBDIR="$(get_libdir)/ocaml" \
+ MANDIR="${ED}/usr/share/man/man3o" \
+ DESTDIR="${ED}/usr" \
+ install
+ dodoc AUTHORS Changelog README
+}